How do I run game in linux?

Get help using Construct 2

Post » Tue Jul 08, 2014 5:43 pm

I export any game for linux and does not open, same thing for Mac. How to solve?
B
3
S
1
G
1
Posts: 17
Reputation: 605

Post » Tue Jul 08, 2014 6:00 pm

diegoalvess wrote:I export any game for linux and does not open, same thing for Mac. How to solve?

I think there is no way to achieve that.. node webkit only works in mac and windows.
ps: qualquer dúvida pode me mandar uma pm, sou brasileiro tmb.
fico feliz em ajudar (se eu puder) hehe
abraço
B
20
S
4
Posts: 387
Reputation: 2,274

Post » Tue Jul 08, 2014 7:52 pm

Zathan wrote:
diegoalvess wrote:I export any game for linux and does not open, same thing for Mac. How to solve?

I think there is no way to achieve that.. node webkit only works in mac and windows.
ps: qualquer dúvida pode me mandar uma pm, sou brasileiro tmb.
fico feliz em ajudar (se eu puder) hehe
abraço


I guess I was not clear. I can not run the game that I exported to linux and mac. Simply does not open.

I still can not send private messages ... When you have enough reputation can converse in Portuguese private.

I'm sorry if any grammar error, I'm using google translator.

thanks!
B
3
S
1
G
1
Posts: 17
Reputation: 605

Post » Tue Jul 08, 2014 9:56 pm

@diegoalvess
But you are using node webkit to export, right?
If so, i think the linux version never will work, cause isn't supported..
About the mac version.. did you tested in a mac?
B
20
S
4
Posts: 387
Reputation: 2,274

Post » Wed Jul 09, 2014 4:36 pm

@Zathan

Yes, but when you export the project to construct 2 gives me 4 folders, win 32, linux 64bit, 32bit linux and mac. Since only win 32 bit works. The others not.

Look this :

Linux 32bits : goo.gl/uCb7EQ
Linux 64bits : goo.gl/zAxvU3
Windows 32 e 64 bits : goo.gl/DqW6tC
Mac : goo.gl/MGpruu
B
3
S
1
G
1
Posts: 17
Reputation: 605

Post » Wed Jul 09, 2014 5:04 pm

What Linux distribution do you use?

Node-webkit is plagued right now by being built against an ancient set of libs. So for example every ubuntu after 12.10 won't work.
To get the exact error don't click on it, but navigate to your exported files with a terminal and start from there.
B
78
S
28
G
32
Posts: 481
Reputation: 19,788

Post » Fri Jul 11, 2014 6:54 pm

Eisenhans wrote:Node-webkit is plagued right now by being built against an ancient set of libs. So for example every ubuntu after 12.10 won't work.


I'm using ubuntu 14.04 .... Now What do I do? :(
B
3
S
1
G
1
Posts: 17
Reputation: 605

Post » Fri Jul 11, 2014 7:30 pm

Did you make sure all the files have access?
Image ImageImage
B
170
S
50
G
179
Posts: 8,379
Reputation: 113,427

Post » Fri Jul 11, 2014 10:25 pm

B
7
S
1
Posts: 57
Reputation: 484

Post » Sun Jul 13, 2014 4:14 pm

newt wrote:Did you make sure all the files have access?


Yes man. :/


caplocks1111 wrote:This will help you, https://www.scirra.com/tutorials/880/ho ... ect-to-exe


My problem this is linux... Not windows...
B
3
S
1
G
1
Posts: 17
Reputation: 605

Next

Return to How do I....?

Who is online

Users browsing this forum: No registered users and 37 guests