How do I Save Sound & Music Settings?

Get help using Construct 2

Post » Fri Jun 06, 2014 6:12 pm

I'm having some trouble using Webstorage to save my sound & music settings so that the users setting preference stay if they exit the game.

I've searched online and found a few examples and tutorials of using webstorage to save settings but i've not been able to get them to work with mine, it maybe because i'm using Global Variables to control my sound settings, i'm not 100% sure why it's not working.

I would appriciate it if someone can explain/show me how to do this as i want to know why it isn't working for me as i've used Webstorage just fine when it comes to saving a highscore.

I've provided a capx file that i've quickly made so it stays under the 2mb limit if needed.

Thanks
You do not have the required permissions to view the files attached to this post.
B
5
S
2
Posts: 116
Reputation: 867

Post » Sun Jun 08, 2014 2:25 pm

Anyone? I've been at this for a while now and can't get it to work. I could do with some help.
B
5
S
2
Posts: 116
Reputation: 867

Post » Wed Jun 11, 2014 2:52 pm

Sorry to bump this but i could really do with some help on this....
B
5
S
2
Posts: 116
Reputation: 867

Post » Wed Jun 11, 2014 3:18 pm

In your capx you're never actually passing the music/sound info to Webstorage.. you're just setting a global variable with it. If you look at how you're setting the high score & repeat that process for the sound / music, you should be ok..
Made Cosmochoria - www.cosmochoria.com
Currently working on Slayaway Camp - www.slayawaycamp.com
B
27
S
8
G
3
Posts: 384
Reputation: 5,020

Post » Wed Jun 11, 2014 4:41 pm

Thank you for replying. I just realised i uploaded the capx without saving what i tried for saving webstorage, the capx provided is just a basic that i use to test things.

I have tried to implement my highscore webstorage settings to my sound & music settings but i can't get it to work. I'll try and post a capx of what i've tried later on if i can. In the meantime, if someone can perhaps show me how it's done with the capx provided then that would be appriciated.
B
5
S
2
Posts: 116
Reputation: 867

Post » Thu Jun 12, 2014 3:01 pm

I've provided a capx of an example of what i've tried. I've had numerous different attempts but havent made it work.

I admit i'm not the best when it comes to Webstorage so i'm expecting someone to tell me that i've done this completely wrong :)

Hope someone can help.
You do not have the required permissions to view the files attached to this post.
B
5
S
2
Posts: 116
Reputation: 867

Post » Thu Jun 12, 2014 10:46 pm

Can anyone help out? Sorry to keep posting but this is a really frustrating issue for me as i can't get it to work.

Thanks.
B
5
S
2
Posts: 116
Reputation: 867


Return to How do I....?

Who is online

Users browsing this forum: brunopalermo, maranpis, missile, oosyrag, Yahoo [Bot] and 31 guests