How do I set desktop game to not fullscreen?

Just started using Construct 2? Post your questions here

Post » Wed May 27, 2015 9:20 pm

In project options I turned on full screen. Result: mobile and non-mobile are full screen.

But I wish to set non-mobile to not-full screen.
I have tried the browser object and: if on mobile (inverted) > browser object: cancel full screen.
But that doesn't work. :(


The other way around (detect if mobile is used and only set mobile to full screen gives unwanted stretched zoomed in result, on my mobile), so that's why I am asking it like this.
B
28
S
6
G
7
Posts: 678
Reputation: 5,676

Post » Wed May 27, 2015 10:43 pm

applehiku wrote:The other way around (detect if mobile is used and only set mobile to full screen gives unwanted stretched zoomed in result, on my mobile), so that's why I am asking it like this.


What full screen option are you using in the browser object's request fullscreen action?
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Thu May 28, 2015 11:31 am

Sounds like you're taking it the wrong way.
Set the project property "Fullscreen" to off.

So by default no device will be fullscreen. inside the boundaries of the browser the game is executed in.

Be sure to add a browser object to your fullscreen and on start of layout test if you are on mobile device. If so, then require fullscreen from the browser object.
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
292
S
115
G
96
Posts: 7,295
Reputation: 70,795

Post » Fri May 29, 2015 7:24 pm

LittleStain wrote:
applehiku wrote:The other way around (detect if mobile is used and only set mobile to full screen gives unwanted stretched zoomed in result, on my mobile), so that's why I am asking it like this.


What full screen option are you using in the browser object's request fullscreen action?


Hi @Kyatric, thanks for your reply. Yes I just tried that again.
Here is my result and answer to @LittleStain:

Sorry for my late reply.
I have tried them all. :)
All request full screen options are full screen on my android mobile (that's good), but also zoomed in, so only the center area is visible of the layout.

I have also just tried the following:
- create a new project
- resolution 200, 320
- full screen off (project property)
- on any touch, request browser full screen (tried all 6 full screen options)
Result: browser ok (in a frame). On mobile: same "problem": fullscreen, but very much zoomed in. Only the center and/or upper part of the screen is visible.

Am I doing something wrong? Is this a bug or a feature wish? :)


(my mobile is using android 4+ and I am using Chrome mobile)
B
28
S
6
G
7
Posts: 678
Reputation: 5,676

Post » Fri May 29, 2015 7:59 pm

That is very unexpected..

Do you perhaps have old events scaling the layout and/or layers you forgot to turn off?
Did you change the settings of your chrome browser on your mobile (zoom) ?
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Fri May 29, 2015 9:39 pm

Old events? No, I also experience it in a new (almost empty) project. :)
I just checked my mobile chrome browser: zoom option is turned off. It makes no difference if I use the mobile or desktop view and I just deleted the browser cache & coocies, closed all open tabs and restarted the phone.

Should I file a bug report? :)
B
28
S
6
G
7
Posts: 678
Reputation: 5,676


Return to Beginner's Questions

Who is online

Users browsing this forum: No registered users and 3 guests