How do I setup local network preview?

Get help using Construct 2

Post » Wed Apr 27, 2016 9:58 am

I have followed setting up the local preview on my network and I am unable to get it working.
Steps taken:
Setup preview server port 50000 and my laptops local ip 192.168.0.12
Restarted construct2 as administrator
Allowed incoming connections in windows firewall on port 50000

When I use another device (another laptop, iphone, ipad) using chrome and safari it times out
and tells me the server is not responding..
Am I missing something here?
B
7
S
1
Posts: 18
Reputation: 423

Post » Wed Apr 27, 2016 4:09 pm

Did you test it up as: 192.168.0.12:50000 on the other devices or did you just use the ip address? You'll want to tack on the ":50000"
B
65
S
39
G
24
Posts: 352
Reputation: 18,106

Post » Wed Apr 27, 2016 4:14 pm

Yes, I added the port number
B
7
S
1
Posts: 18
Reputation: 423

Post » Wed Apr 27, 2016 4:19 pm

You need to preview your game and then start it remotely - at least this was my problem at first.

  • System > On start of layout | system > load game from slot "brain"
  • System > On load failed | system > scroll to obj_Forum
B
17
S
8
G
5
Posts: 340
Reputation: 4,707

Post » Wed Apr 27, 2016 4:23 pm

By preview do you mean run it on my local laptop in a browser before opening on remote device? .. if so I am doing this
B
7
S
1
Posts: 18
Reputation: 423

Post » Wed Apr 27, 2016 4:39 pm

Yes,
start local laptop preview > then start remote browser

also your IP address could be changed every time you connect to your WIFI
best practice is to visit your router and - if possible - give your laptop (MAC adress) a fixed/preferred IP or change your laptop to a static address.

Can you ping your laptop?
From another computer open command prompt (cmd) and type "ping 192.168.0.12"
On a phone you need an app like FING for Android

  • System > On start of layout | system > load game from slot "brain"
  • System > On load failed | system > scroll to obj_Forum
B
17
S
8
G
5
Posts: 340
Reputation: 4,707

Post » Wed Apr 27, 2016 5:15 pm

Thanks for your suggestions appears to be a win8 network issue, cannot ping, even after I disable firewall
B
7
S
1
Posts: 18
Reputation: 423

Post » Fri Apr 29, 2016 4:06 pm

Try localhost or 127.0.0.1
https://www.ravenheart.ca/home
I don't check the forums much anymore, but I will receive an email for PMs.

"Someone once told me I bite off more than I can chew...

I told them I would rather choke on greatness than nibble on mediocrity."
B
22
S
6
G
1
Posts: 1,418
Reputation: 4,830


Return to How do I....?

Who is online

Users browsing this forum: jatin1726 and 28 guests