How do I Solve This

Get help using Construct 2

Post » Wed Jul 19, 2017 8:47 am

When my character jumps on a wall, he just slide slowly down.
I think it's a bug
how do i fix this? :cry:
B
1
Posts: 5
Reputation: 135

Post » Wed Jul 19, 2017 11:25 am

If you are using platform behavior, the wall's needs to be solid.

Give us more info by posting a screenshot or something, I can only guess like this.
Like my work? Fallow me on social media, and see my games on the arcade.
B
7
S
5
G
9
Posts: 298
Reputation: 5,357

Post » Wed Jul 19, 2017 9:53 pm

Might be a problem with your collision polygons. Usually when I get platform behaviour weirdness it's because I forgot to set collisions properly.
Image



Coming soon on Steam!
B
16
S
9
G
3
Posts: 201
Reputation: 3,460

Post » Mon Jul 24, 2017 6:40 pm

Message: LikeAlex2010 can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
imhotep22 wrote:If you are using platform behavior, the wall's needs to be solid.

Give us more info by posting a screenshot or something, I can only guess like this.

http://imgur.com/a/99LPl It just slides down or stay like this... i don't know what to do
B
1
Posts: 5
Reputation: 135

Post » Mon Jul 24, 2017 7:05 pm

LikeAlex2010 wrote:http://imgur.com/a/99LPl It just slides down or stay like this... i don't know what to do


I would advise to post your .capx as fault finding from just an image is very difficult.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
131
S
29
G
81
Posts: 5,328
Reputation: 56,630

Post » Mon Jul 24, 2017 7:41 pm

Message: LikeAlex2010 can only post plain text URLS until they have 500 rep. 2 URLS modified. Why?
zenox98 wrote:
LikeAlex2010 wrote:http://imgur.com/a/99LPl It just slides down or stay like this... i don't know what to do


I would advise to post your .capx as fault finding from just an image is very difficult.

https://youtu.be/pWXvPwCycbg There is a video with the problem, but now i can't post a .capx ...
B
1
Posts: 5
Reputation: 135

Post » Mon Jul 24, 2017 7:57 pm

From what I seen in the video, the character slides only on the edge of the platform, if that is correct then it seems there is a collision polygon problem because the platform looks a little lit sloped near the edges, sadly if you are using a tiled background you cannot change the collision so you will probably need to fill the edges to be exact like the rest of the platform, if its a sprite then you can check the collision polygon and adjust it a bit on the edge.

I had a similar problem on my latest platform game I am working on, I had a sloped tile but the player was not sliding on it because it was a tile background and the collision was a square instead if a triangle, I fixed it by changing the image to sprite so I can adjust its collision and after that it worked fine at a cost at slight performance change.
Like my work? Fallow me on social media, and see my games on the arcade.
B
7
S
5
G
9
Posts: 298
Reputation: 5,357


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 7 guests