How do I stay on platform when animated

Get help using Construct 2

Post » Fri Mar 14, 2014 12:58 am

I'm new to construct and having trouble keeping my moving sprite in the same place when I add animations to it. it is a simple image of a running person on a platform. if I remove the animation it works perfect and stay in place, but when I add some frames to the sprite he randomly shows up on different parts of the pages on the platforms not matter how fast the frames rotate? Any help is appreciated.
B
3
G
1
Posts: 8
Reputation: 341

Post » Fri Mar 14, 2014 2:05 am

You have to set the origin point for your frames. Check the manual page here
B
84
S
22
G
15
Posts: 1,039
Reputation: 15,249

Post » Fri Mar 14, 2014 9:11 am

And remember to post beginner questions in the correct forum :)
I will not let you reach the sisters
Nature Forums
B
11
S
5
G
2
Posts: 496
Reputation: 2,306

Post » Wed Mar 19, 2014 2:03 am

Yeah this is still not working, I'm trying 2 animations for the characters "Default" and "Jump". Default has 5 frames and the jump is 1 frame. I already had all the frames with the same origin point. Am i supposed to be setting the animations origin point when i change the animation on jump. Appears the animation changing to jump is fine, just when he is on the platform running he either starts sliding backwards quickly or fly's way ahead to a random point. That manual reference just showed me how to set or create image points which I've found to be useful for spawning objects from that point but not sure how it applies to animations and doesnt speak of it in the link?
B
3
G
1
Posts: 8
Reputation: 341

Post » Wed Mar 19, 2014 3:09 am

i figure it out by finding another guys sample animation online, he is using an object and just placing the sprite images over it and just changing it on tick, simple enough. thanks for yalls help!
B
3
G
1
Posts: 8
Reputation: 341


Return to How do I....?

Who is online

Users browsing this forum: bclikesyou, kellehk, ST314 and 23 guests