How do I stop driving controls default to arrow keys?

Get help using Construct 2

Post » Mon Jan 12, 2015 1:48 am

I'm making a driving game, and I have set custom controls for the car. I have the "Default" Controls set to off or "No", but the arrow keys still allow the car to be driven. If i test the game in the driving layout the arrow keys are off, but if I test from the beginning layout, they control the car again. Any ideas?

I'll put the .capx in later.
B
7
S
1
Posts: 57
Reputation: 728

Post » Tue Jan 13, 2015 4:03 am

Need a capx
Image
B
75
S
23
G
3
Posts: 673
Reputation: 9,283

Post » Wed Jan 14, 2015 6:39 am

Here's the .capx
You do not have the required permissions to view the files attached to this post.
B
7
S
1
Posts: 57
Reputation: 728

Post » Wed Jan 14, 2015 6:47 am

Hi, your player sprite has default controls set to yes on your StarMenu layout. Fix that and it will work.
B
67
S
23
G
9
Posts: 166
Reputation: 7,339

Post » Sat Jan 17, 2015 6:46 am

neverk wrote:Hi, your player sprite has default controls set to yes on your StarMenu layout. Fix that and it will work.


I have already tried that, the arrow keys still give control even when set to no.
B
7
S
1
Posts: 57
Reputation: 728

Post » Sat Jan 17, 2015 6:49 am

Nevermind, I didn't even realized the first layout affected the next layout.

Solved! Thanks @neverk
B
7
S
1
Posts: 57
Reputation: 728

Post » Fri Mar 06, 2015 3:32 pm

Is there a way to toggle or dynamically set this setting between layouts? (I've tried disabling 'default controls' and recoding them still using arrows) and tried putting the controls in a condition 'userControl=1', but I can't seem to toggle user control altogether.
B
3
Posts: 5
Reputation: 185


Return to How do I....?

Who is online

Users browsing this forum: cb130felix, Kermad, Lancifer, mongoose665, piddlyPoo, yiuyiu6666 and 3 guests