How do I stop from shadows going through solids?

Just started using Construct 2? Post your questions here

Post » Fri Dec 09, 2016 7:56 pm

Message: Vodakman can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
Title says it all.

The shadow system is working alright, but the shadows go through solids/walls, which doesn't look pretty nor nice.
I couldn't think of anything to fix this problem, so hopefully you guys can help me.

.capx link: http://www.mediafire.com/file/3p9rmhxd7gdp6qp/ShadowTest.capx
B
7
Posts: 34
Reputation: 345

Post » Fri Dec 09, 2016 11:07 pm

The shadows are rendered on top of the solids, that's why.
Either move the ShadowLight's Z index below the solids or Create a new layer, put the ShadowLight on that layer and move the layer below "Layer 0".
"We can't solve problems by using the same kind of thinking we used when we created them."
- Albert Einstein
B
27
S
11
G
8
Posts: 528
Reputation: 7,091

Post » Sat Dec 10, 2016 10:19 am

Yeah, I got it working now, thanks.
B
7
Posts: 34
Reputation: 345

Post » Mon Dec 12, 2016 2:14 pm

The "Light Radius" setting can also cause the affect to see through the edges of bordering sprites even as solids. Turning down the light radius can soften that edging affect. Just a tip... I run into that sometimes.
B
18
S
6
G
7
Posts: 44
Reputation: 4,665


Return to Beginner's Questions

Who is online

Users browsing this forum: No registered users and 2 guests