How do I stop monster sprites going through solid

Get help using Construct 2

Post » Thu Oct 25, 2012 1:25 pm

Hi All

I'm using the top-down shooter in tutorial 1.

I have placed some "solid" sprites (walls) in the scene and my player sprite doesn't go through the walls, which is correct.

However all the monster sprites do go through the walls, even though they shouldn't. I have set their 'bounce of solid' property to Yes and still they're going through the solid objects.

What am I missing please?

Thank you
Mark
B
14
S
2
Posts: 7
Reputation: 981

Post » Thu Oct 25, 2012 2:10 pm

Please post your capx
B
42
S
19
G
12
Posts: 723
Reputation: 13,911

Post » Thu Oct 25, 2012 4:41 pm


Thank you - I've put the capx at http://www.wolfpaw.co.uk/capx/begining.capx

Been looking through it again and still can't see why the enemy mobs are moving through solids :(
B
14
S
2
Posts: 7
Reputation: 981

Post » Thu Oct 25, 2012 7:46 pm

Not sure if it makes a difference but the player sprite is defined with a behaviour of of 8-direction whereas the monster sprites are defined with a behaviour of bullet.

Does this mean bullets don't stop at solids?
B
14
S
2
Posts: 7
Reputation: 981

Post » Thu Oct 25, 2012 11:01 pm

You have 'bounce off solids' set to 'No' in that capx. Setting it to 'Yes' makes them bounce off the walls.
B
54
S
28
G
18
Posts: 1,520
Reputation: 25,000

Post » Fri Oct 26, 2012 1:06 pm

Ramones thank you for taking the time to check my capx file.

You're right! I had bounce off solids = No. I set it to Yes and also Set Angle=Yes and it's working.

Your help much appreciated :)
B
14
S
2
Posts: 7
Reputation: 981

Post » Tue Aug 25, 2015 2:08 am

Where does that get set at?
B
16
S
6
Posts: 46
Reputation: 1,194


Return to How do I....?

Who is online

Users browsing this forum: Artpunk, GenkiGenga, Kagubro, Mirlas, zeneizel and 24 guests