How do I test IAP for IOS

Get help using Construct 2

Post » Wed Apr 01, 2015 3:37 pm

in Intel xdk I have added icons and splash screens in the relevant section and then built the system. When I upload the game using application loader I get this error submitted to intel xdk folks. https://software.intel.com/en-us/forums/topic/544719

I am wondering how are you not getting it.
B
5
S
1
Posts: 41
Reputation: 466

Post » Wed Apr 01, 2015 3:41 pm

I have to admit that i have no clue why you are getting it. Try to restart a new project on xdk and upload the files i hope it will help
B
8
S
2
Posts: 130
Reputation: 970

Post » Wed Apr 01, 2015 11:09 pm

i will do it today.

One question. Are you adding the icons and splash screens in the Intel XDK build options or in the additions.xml file?
B
5
S
1
Posts: 41
Reputation: 466

Post » Thu Apr 02, 2015 5:55 am

Inside the xdk. And you need also these files to be on the exported project root folder. First add then to root then pick them from the xdk
B
8
S
2
Posts: 130
Reputation: 970

Post » Thu Apr 02, 2015 1:31 pm

have you put any cfbundleid verion number in IOS build settings?
B
5
S
1
Posts: 41
Reputation: 466

Post » Thu Apr 02, 2015 1:38 pm

yes you have to - that is the parameter that determines the version number on the app store
B
8
S
2
Posts: 130
Reputation: 970

Post » Thu Apr 02, 2015 2:18 pm

The icon problem has disappeared by moving the icons to root directory. Now when I am trying to upload the image using application loader, it is getting stuck in the "sending API usages to itunes Connect" stage. After 15 minutes I am getting a timeout message.

Have import the IPA or choose the ipa for review in application loader?
B
5
S
1
Posts: 41
Reputation: 466

Post » Thu Apr 02, 2015 3:04 pm

in application loader --> deliver your app --> upload the ipa --> done !
B
8
S
2
Posts: 130
Reputation: 970

Post » Fri Apr 03, 2015 12:32 am

I did resolve the image [email protected] not found issue while loading ipa to APP store using application loader.

The resolution is when you add the icons to Intel XDK, 180x180 icon should be lower case png for IOS. I did write like 180.PNG.

Intel XDK copies all other icons without the file extension and adds the png to the extension by itself. But for this 60x3 =180 size icon it copies the whole name.
While application loader performs asset check the icon with .PNG fails.

It took a tremendous amount of time for me to figure a silly issue. Good thing is that I understand the Intel XDK build log in a better way now.

Sagar
B
5
S
1
Posts: 41
Reputation: 466

Post » Sun May 03, 2015 2:36 am

Vegamon007 wrote:Hey guys I have a quick question. When you export using Intel XDK, what provisioning file do you use?

The Apple documentation seems to say you need to use a development provisioning file however Intel XDK only lets you build using Ad Hoc or Production. Would anyone be able to clarify this?


For the Intel XDK build I uploaded 2 profiles, the adhoc and the production profile. If you upload the development one your build will fail.
Image
B
15
S
4
G
4
Posts: 134
Reputation: 3,177

PreviousNext

Return to How do I....?

Who is online

Users browsing this forum: ColombageEnPLS, darkrealos, pmerineau, Yahoo [Bot] and 6 guests