How do I use Blend modes?

Get help using Construct 2

Post » Tue Dec 09, 2014 4:45 pm

According to the Blend Mode example file, it looks super simple but I can't recreate it. So in the example file, the 2 sprites seem to interact with each other but when I try to recreate it the sprite with a blend effect only interacts with the background, not the other sprite.

For example: Create new project. Create new layer on top. Make sure layer is transparent. Make sure layer is active. Insert 1st object. Insert 2nd object. Move second object to partially overlap 1st. Set send object to blend "Source Atop". Expected behavior: I only see the portion of 2nd object that is overlapping object 1. Actual behavior: No change.

Blend mode: Destination Over. Expected behavior: 1st sprite renders over 2nd sprite, despite 2nd sprite being on top in the Z-order. Actual behavior: 2nd sprite disappears (rendered underneath the background?)

Another blend mode: Additive. Expected effect: Overlapping area turns very bright relative to the two sprites. Nonoverlapping area remains the same. Result: 2nd sprite turns entirely white.

If I change the background to black (with additive still in effect) the 2nd sprite turns into a ghost image. Showing that the blend is only interacting with the background, not the 1st sprite like I expect it to in the Blend Mode Example file.

So how do I get the effect I want where the blend mode uses Sprite 1 and not the background?
B
10
S
2
G
2
Posts: 73
Reputation: 1,044

Post » Tue Dec 09, 2014 5:18 pm

In the layer properties for the layer that has your objects with the blend modes, you need to turn on "Force own texture".
Moderator
B
113
S
41
G
20
Posts: 1,586
Reputation: 19,126

Post » Tue Dec 09, 2014 6:25 pm

That's it! Thanks @Linkman2004!
B
10
S
2
G
2
Posts: 73
Reputation: 1,044


Return to How do I....?

Who is online

Users browsing this forum: zenox98 and 29 guests