How do I use VectorX the proper way

Get help using Construct 2

Post » Wed Jan 04, 2017 11:07 am

Hi guys,

this might sound stupid, but I'm not sure if I use the "Set vector X" action right.

I'm trying to make an attack where the player moves fast forward, so I decided to set the vector x of the player to 500 (in order that the player would move 500 px in a second).
This works fine for "Set Vector Y" but however the player just moves a little. Even if a set the value to 100000 it still just moves a little bit.

Image

I'm not sure what I'm doing wrong. Thank you!
Image Image iTunes: Match3 | Google Play: Match3
B
124
S
44
G
32
Posts: 1,208
Reputation: 30,507

Post » Wed Jan 04, 2017 12:09 pm

I suspect your events are being negated by the player's max speed setting in the platform behaviour. I suggest you temporarily increase the max platform speed to enable this (and maybe change the deceleration as well).
Learning other engines, but C2 still rocks. Image Image Image Image
B
81
S
22
G
96
Posts: 2,468
Reputation: 58,353

Post » Thu Jan 05, 2017 9:54 am

Colludium wrote:I suspect your events are being negated by the player's max speed setting in the platform behaviour. I suggest you temporarily increase the max platform speed to enable this (and maybe change the deceleration as well).


Thanks for your reply. That's what I thought as well. I'll try to make a workaround for it.
Thank you!
Image Image iTunes: Match3 | Google Play: Match3
B
124
S
44
G
32
Posts: 1,208
Reputation: 30,507


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 4 guests