How do I use Video plugin on mobile devices

Get help using Construct 2

Post » Sun Jun 22, 2014 8:40 pm

Hi everybody.

Currently I am trying to use the Video plugin to create some kind of splash screen. In the beginning of my game I have a layout with only one object: Video object, the purpose of this object is to play a video, which I have already imported to my project, that will simulate an animated intro splash screen and, when it finishes, the main menu will appear. My problem is that whether I use cocoonjs launcher or I import my game using Intel XDK as crosswalk android app the video will never start and instead a plain white screen will appear. In the video plugin documentation says something about the plugin being unable to play a video unless a touch event is used to trigger the video, of course I would reather avoid such a thing since I am trying to create a splash screen but even following this workaround I was unable to play any video whatsoever.

I would appreciate any help you could give me.
B
10
S
3
Posts: 75
Reputation: 864

Post » Thu Jun 26, 2014 12:26 am

any help? please??
B
10
S
3
Posts: 75
Reputation: 864

Post » Thu Jun 26, 2014 1:45 pm

Attach a .capx. I'd tested it on Android and iOS and video successfully played providing you touched the screen.
Scirra Founder
B
403
S
238
G
89
Posts: 24,659
Reputation: 196,165

Post » Fri Jun 27, 2014 2:04 am

Hi @Ashley here it is:

Danna On Ice capx

Thank you for answering btw.

I will take this opportunity (I dont often get help directly from a scirra founder :P ) to ask for help about other issues with the same project. On a previous post I asked for help because I am being unable to use accelerometer on my mobile device on this project. As you will see this game is supposed to be played with mobile accelerometer, however, even following this tutorial https://www.scirra.com/tutorials/809/ho ... -crosswalk I was unable to make it work (it is worthy to note that I activated the corresponding plugin options on the app details when building my app in the Indel XDK app). Today I noticed something else: music wont pause/resume when the corresponding touch event triggers (I do know that the event is being triggered and the actions are ocurring somehow because I have tested it on cocoonjs and it works), so in conclusion, something is going on with the interaction between the intel XDK and the Construct events at some point (at least that would be my bet but I am not sure). By the way, if you test this game with cocoonjs launcher you will notice some kind of a white frame on the bottom of the screen, this wont happen if you build the game with Intel XDK (if I actually compile the game using ludei platform the frame will persist), this last issue is just for you to know supposing it is not actually my fault, thank you again ashley.
B
10
S
3
Posts: 75
Reputation: 864

Post » Fri Jun 27, 2014 3:11 pm

@Ashley maybe you could post a capx of your video that works - I tried Jhonathan's file and it failed on cocoonJS player iOS 5S with Not implemented createElement: video like here viewtopic.php?f=147&t=108490&p=797599#p797599
B
6
S
1
G
2
Posts: 6
Reputation: 1,241

Post » Fri Jun 27, 2014 4:26 pm

@Rob2 thank you for trying my file on that device, since I only have an android device I had not tested it on an IOS-based device so I didnt know how it was behaving
B
10
S
3
Posts: 75
Reputation: 864

Post » Mon Jun 30, 2014 3:27 pm

Thats fine :) Despite being around for a couple of years I have been somewhat distracted so am still a C2 noob. Will happily test things on iOS via the launcher if it is helpful but my iOS dev certs have lapsed :/ so can't do a true test.
B
6
S
1
G
2
Posts: 6
Reputation: 1,241

Post » Thu Jul 03, 2014 11:56 pm

@Ashley any luck with my .capx?
B
10
S
3
Posts: 75
Reputation: 864

Post » Mon Jul 07, 2014 4:55 pm

could somebody, anybody lend me a hand on this? I´d really appreciate it
B
10
S
3
Posts: 75
Reputation: 864

Post » Fri Oct 03, 2014 10:44 pm

Dear friends,

I have the same problem.....the video plugin builded with intel sdk with crosswalk for android...don't work....can some body help me??? please?? i have also putted a button to start the video..... but nothing!!!!

The video plugin preview in contruct2 work with firefox browser also preview over wi-fi..work...I have tralslated my video in the 3 format requested by construct....and loaded in.....i have putted the videointro with preload setting...because it work fine with construct 2...work also in webnodekit for windows32..that i have tested....

i would like to make a splash video intro ....can someone help me please????? is there a way to make it work??????

best regards,

lestroso :oops:

http://www.fasasoftware.com
B
4
S
1
Posts: 73
Reputation: 504

Next

Return to How do I....?

Who is online

Users browsing this forum: No registered users and 28 guests