How do I use Video plugin on mobile devices

Get help using Construct 2

Post » Sat Oct 04, 2014 5:34 pm

Hi again to everybody.....

is it possible that only me have this problem???

I saw that also video plugin don't work in Cooconjs on IOS......

But my problem is that Video plugin don't work in crosswalk for android!!!

The scirra support should fix this problem, because this plugin is unsable!!!

Can somebody help me?? please???

Is there another video plugin third part for free????

Best regards,

Lestroso :oops:

http://www.fasasoftware.com
B
4
S
1
Posts: 73
Reputation: 504

Post » Tue Nov 11, 2014 9:56 pm

any new on this? im trying to make a video app for mobiles..
B
37
S
9
G
8
Posts: 541
Reputation: 8,554

Post » Wed Nov 12, 2014 10:05 am

DEAR xanxion,

SCIRRA told me that in the next release of construct2 will fix the problem......

Best regards,

Lestroso :D

http://www.fasasoftware.com
B
4
S
1
Posts: 73
Reputation: 504

Post » Mon Nov 17, 2014 3:57 pm

Hi @fasasftware You know on which build they are going to fix it?
B
86
S
25
G
11
Posts: 652
Reputation: 11,051

Post » Mon Nov 17, 2014 6:55 pm

I'm sorry but i don't know ...i hope as sooon as possible...bye lestroso.... :oops:
B
4
S
1
Posts: 73
Reputation: 504

Post » Fri Apr 10, 2015 7:10 pm

So I'm having the same issue.

Specs:
C2 - R201
Using the video plugin and a webm and mp4 encoding for all videos (both of which play in VLC)
Basic actions to play from source (Note: my project works perfectly fine being run in Firefox, however, both Chrome and the APK generated by Intel XDK fail to play the exported video files)
Intel XDK (latest release as of 4/10)
Export through C2 using Cordova, for Android 4.0+

With all the above, I have exported my project and nothing is shown on my Android device.

I presume this is the same issue that causes Chrome to not play anything in the project.

Does anyone have any fix for this? It seems to be an awfully common error with little discussion.

Could this perhaps be an issue with permissions? Using the newest version of XDK, I have not added any other permissions because I presumed that, because nothing was noted in the manual, I would not need to check anything additional.
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,826

Post » Mon Apr 13, 2015 4:42 am

Bump...
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,826

Post » Mon Apr 13, 2015 10:45 am

Im also trying to get this to work but with no success. Is it even possible to have a video in a crosswalk built app? Or should i just give up?
B
11
S
4
G
2
Posts: 116
Reputation: 1,936

Post » Mon Apr 13, 2015 1:53 pm

@DetteMan What is confusing is that others seem to have gotten it to work.

But also, what encoding did you use? I'm thinking perhaps apps do not support all codecs available, and developers are not being told how to encode videos.

In my case my mp4 file was in h.264, while me WebM was VP9. I think I may try a combination of a few different mp4 encoding and the older VP8 for the WebM version.
Last edited by DatapawWolf on Mon Apr 13, 2015 1:58 pm, edited 1 time in total.
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,826

Post » Mon Apr 13, 2015 1:55 pm

@FredQ
I saw that you have managed to get it working. I've tried only using WebM format but it still does not work after export. It works when previewing on the computer. Have i missed something?
B
11
S
4
G
2
Posts: 116
Reputation: 1,936

PreviousNext

Return to How do I....?

Who is online

Users browsing this forum: David181, yiuyiu6666 and 29 guests