How do I use Video plugin on mobile devices

Get help using Construct 2

Post » Mon Apr 13, 2015 1:58 pm

@DatapawWolf
Im not sure about encoding. How can i see that? I've just tried converting the video to a bunch of different formats.
B
11
S
4
G
2
Posts: 116
Reputation: 1,936

Post » Mon Apr 13, 2015 2:00 pm

http://developer.android.com/guide/appe ... rmats.html

Ah hah! Take a look at this, @DetteMan. Only VP8, and then for MP4, a few other types of encoding that I was not using.

Also, yeah, if launching to And our 4.0+, all that is needed is this VP8 WebM. Also would be handy to know so as to not bloat exports unnecessarily.
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,826

Post » Mon Apr 13, 2015 2:03 pm

@DetteMan, you can see detailed information using VLC. I'm in my phone right now so I cannot give you. Detailed how to, but the functionality is there. : )
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,826

Post » Mon Apr 13, 2015 2:08 pm

@DatapawWolf
Oh, great. I'm also on my phone but I am going to check it out once I'm home. Let me know if you get it to work.
B
11
S
4
G
2
Posts: 116
Reputation: 1,936

Post » Mon Apr 13, 2015 2:10 pm

I'll definitely post about it when I can. I also have college classes, heh, so we shall see when I finally get to work on it. Hopefully at least tonight.
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,826

Post » Tue Apr 14, 2015 2:19 pm

@DatapawWolf
Any luck? I tried to convert to a bunch of formats with different codecs in VLC but just cant seem to get it to work. One wierd thing is that in the XDK emulator the video wont show. But, if I change the device to samsung galaxy S it works. Thinking if its because it probobly run on Android 2.3?
B
11
S
4
G
2
Posts: 116
Reputation: 1,936

Post » Tue Apr 14, 2015 5:29 pm

DetteMan wrote:@FredQ
I saw that you have managed to get it working. I've tried only using WebM format but it still does not work after export. It works when previewing on the computer. Have i missed something?


I don't know if this will help but here's some more information.

I built with Crosswalk 10, I've not tried it with 7 so I'm not sure if it works with that version and VLC Player tells me the video codec is VP8.

If you want to see it in action my app is at:
https://play.google.com/store/apps/details?id=com.quiz90tv.nsgames

Click the green man on the menu, it'll take you to a layout with a promo video for another game I have.
ImageImage
Mr. Green - Platform/puzzle game out now!
B
25
S
7
G
1
Posts: 222
Reputation: 3,350

Post » Tue Apr 14, 2015 6:39 pm

Thank alot @FredQ
that gave me some hope that at least its possible some way.
B
11
S
4
G
2
Posts: 116
Reputation: 1,936

Post » Tue Apr 14, 2015 6:54 pm

FredQ wrote:I built with Crosswalk 10, I've not tried it with 7 so I'm not sure if it works with that version and VLC Player tells me the video codec is VP8.
@FredQ Well I'm even more confused now! I am using that exact codec in my videos, and Crosswalk 10 like you. Not working.

Did you enable anything else with the Android build? Any extra permissions? Did you build with Construct 2 r201+? Did you leave the video files in your Files folder in your Construct 2 project or import them into XDK?

However, my device is only running Android r10. So I'm considering the fact that I need a different video encoding entirely, one that is supported on more Android platforms.
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,826

Post » Tue Apr 14, 2015 7:01 pm

@DatapawWolf
Have you tried the game FredQ liknked to? If that works then there should not be a device problem, right?
B
11
S
4
G
2
Posts: 116
Reputation: 1,936

PreviousNext

Return to How do I....?

Who is online

Users browsing this forum: Artcadev, Baidu [Spider], dop2000, oosyrag and 36 guests