How does construct 2 determine if a browser is not supported

Get help using Construct 2

Post » Wed Mar 09, 2016 8:29 pm

How does construct 2 determine if a browser is not supported? I know for a certainty that the default message which states "Your browser does not appear to support HTML5. Try upgrading your browser to the latest version." appears if one is using a browser that is not compatible with jQuery 2. Is this the only check that construct does? When is this done? Are there any other checks to determine if the browser is html5 compatible and where can I see the code for this? Thanks anyone :)
B
2
Posts: 1
Reputation: 152

Post » Wed Mar 09, 2016 9:01 pm

https://www.ravenheart.ca/home
I don't check the forums much anymore, but I will receive an email for PMs.

"Someone once told me I bite off more than I can chew...

I told them I would rather choke on greatness than nibble on mediocrity."
B
23
S
6
G
1
Posts: 1,419
Reputation: 4,857

Post » Thu Mar 10, 2016 4:26 pm

It only shows that message if the browser does not understand the <canvas> tag - or if the browser is running in a compatibility mode that doesn't support it (e.g. IE11 running a site in IE8 compatibility mode).

The only browsers that don't understand <canvas> are IE8 and older, and some very old Android phone's stock browsers. It's nearly universally supported now!
Scirra Founder
B
399
S
236
G
89
Posts: 24,543
Reputation: 195,430


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 12 guests