How I Make this Pinned Animation reaper after Replay

Get help using Construct 2

Post » Sun Nov 13, 2016 3:50 pm

Hello, I was actually editing a Template, and I put the mechanic sprite as invisible and I pinned the animation sprite to the mechanic.

Works properly after start the game, but after the character dies, and I click on restart the game, the pinned animation just disappears, So I tried to spawn it with the main motor sprite but nothing worked, I am still noob with this and I don't know the solution, I also tried to search.

I attached picture of the cap. And marked the event lines in red the pinned animation is the last picture.

Thank you!

PD: Edited
Last edited by Nivzeor on Sat Nov 26, 2016 9:34 am, edited 1 time in total.
B
7
S
2
G
1
Posts: 2
Reputation: 984

Post » Sun Nov 13, 2016 7:26 pm

Sorry, your images are a bit confusing and can't really tell if anything is incorrect.

I don't see where the Animation is being created or spawned. And can't tell what's going on with the behaviors, such as, is there a fade, any events/action to stop the Animation from being destroyed if it's pinned.

Walk away from it for a bit. Come back and look over any and all behaviors that are associated with the Animation and what it's pinned to.
B
38
S
18
G
19
Posts: 664
Reputation: 14,107

Post » Sat Nov 26, 2016 9:37 am

Hello Jeffige I just did as you said and took a rest with the project, and I found the behaviours where the animation is spawned and fixed it easly.

Thank you, and sorry for the confusing pictures.
B
7
S
2
G
1
Posts: 2
Reputation: 984


Return to How do I....?

Who is online

Users browsing this forum: FlyingRam and 9 guests