How to connect Sound to Car Behaviour

Get help using Construct 2

Post » Fri Jun 12, 2015 7:55 pm

I´m having trouble playing sounds connected to a Car behaviour --> dependent on speed, if its accelerating drifting etc

The sound fires constantly or does not at all.

The examples I´v found are all very straightforward like on collision or mouse click, never to a changing/ ongoing variable.

Thanks.
working on Rally Racing
B
8
S
1
G
2
Posts: 48
Reputation: 1,076

Post » Sun Jun 14, 2015 4:13 pm

@Torpedo You'll need some acceleration/movement speed conditions and then only play the sound once while looping (i'm assuming you know how to trigger the sound only once versus continuously).

Driving sounds
If speed > 0 and < speed 100 and Not turning, Play soundSlowDriveLoop
If speed >= 100 and < speed 200 and Not turning, Play soundMediumDriveLoop
If speed >= 200 and < speed 300 and Not turning, Play soundFastDriveLoop

Driving sounds
If speed > 0 and < speed 100 and turning, Play soundSlowDriftLoop
If speed >= 100 and < speed 200 and turning, Play soundMediumDriftLoop
If speed >= 200 and < speed 300 and turning, Play soundFastDriftLoop
Check out my games on Google Play:
BEAST ATTACK (1,000,000+ downloads!)
ZOMBIE BASH (Android) (Launched Feb 17)
ZOMBIE BASH (iOS) (Launched March 17)
B
55
S
18
G
2
Posts: 436
Reputation: 5,607

Post » Sun Jun 14, 2015 8:36 pm

Thanks for digging up my question @jook00
This is what I come up. Using Trigger Once and "manually" stopping the sounds.

Image

Is this what you meant. It works kindish but to sound anything acceptable I´ll need to blend some more sounds on top. Acceleration Gear Brakes Drifting etc. This setup is kinda messy, having to track all individual sounds and stop them, blending and timming each sound.. sounds like a nightmare.
working on Rally Racing
B
8
S
1
G
2
Posts: 48
Reputation: 1,076


Return to How do I....?

Who is online

Users browsing this forum: boybacteria, dop2000, Microbex, richcoz81, totoe and 31 guests