How to deactivate "Creating Offscreen Canvas"

Get help using Construct 2

Post » Sun May 25, 2014 11:37 am

Hi,
animation of my game are very laggy and slow. Only on a mobile device (iOS).
xcode says: "Creating Offscreen Canvas (2D): size: xxx, retina: yes = xxx, msaa: no"
Every time I created a new object inside the screen, the xcode brings this message.
But I have no drawing object outside the screen.

How to deactivate this?
I think this is the problem vor memory waringings and app crashed and slowdowns.

(Iam using ejecta)
B
13
S
4
G
1
Posts: 107
Reputation: 1,337

Post » Sun Jun 08, 2014 3:07 pm

How to deactivate this?
I think this is the problem vor memory waringings and app crashed and slowdowns.


I had this problem too. I don't think you can turn it off but you can significantly decrease the time it takes to complete.

If you're still having this problem turn off WebGL before you export. Then when you switch layouts you'll still get a slight pause on first load but after that it will switch very quickly.

At least this method worked for me. It may also help to reduce your quality settings. But by far WebGL was the biggest culprit with my project.
B
12
S
1
Posts: 16
Reputation: 1,332

Post » Mon Jun 09, 2014 4:32 pm

Thanks, but I have already solved like you. :)
summary we can say: Contruct 2 don't work correctly with ejecta when WebGL is enabled. unfortunately.
WebGL bringts awesome effects, but don't work on older devices like iPad 3.
B
13
S
4
G
1
Posts: 107
Reputation: 1,337

Post » Sun Jun 15, 2014 2:43 am

Hopefully iOS 8 will fix that :)
B
12
S
1
Posts: 16
Reputation: 1,332


Return to How do I....?

Who is online

Users browsing this forum: AllanR, brunopalermo, ST314, TheRealDannyyy, tunepunk and 22 guests