How to display Chinese characters in the text box?

Get help using Construct 2

Post » Fri Jun 08, 2012 4:16 pm

Hi I'm a Chinese and first-time user of C2. I typed some words in Chinese in the inserted text box, but only some squares were shown. Is there any way to display Chinese text correctly? Sorry if it is a solved issue. Thanks for the help!
B
3
Posts: 2
Reputation: 429

Post » Fri Jun 08, 2012 4:31 pm

I have no experience about words in chinese, but i found something were correct. Look at these pics were used in C2.





I guess you should to try Arial font.
B
96
S
34
G
29
Posts: 3,139
Reputation: 28,236

Post » Fri Jun 08, 2012 8:41 pm

Yes, Construct 2 fully supports Unicode, so I guess the font you're using doesn't.
Scirra Founder
B
386
S
229
G
87
Posts: 24,207
Reputation: 191,692

Post » Fri Jun 08, 2012 9:29 pm

I've tried to reproduce c2 crash, when using Cyrillic characters, but i can't - it works just as it should now. Strange...
B
19
S
6
G
4
Posts: 171
Reputation: 2,512

Post » Sat Jun 09, 2012 4:31 pm

Thanks guys! I tried again, and in the test run the Chinese characters can be displayed. But in the layout area the words cannot be shown. Trying to figure it out...
B
3
Posts: 2
Reputation: 429

Post » Sat Dec 01, 2012 1:39 am

I tried two common Chinese fonts in Windows XP, it works in Beta Release r111.
B
5
S
2
G
1
Posts: 10
Reputation: 1,334

Post » Mon May 20, 2013 5:50 am

how u can display chinese characters?
I try ????? but it not show when I try to run~
B
3
Posts: 1
Reputation: 177

Post » Mon May 20, 2013 6:14 am

@mono Do you mean in C2 editor? It won't show, but runtime does.

B
96
S
34
G
29
Posts: 3,139
Reputation: 28,236


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 8 guests