How to enable WebGL in Node Webkit on Vista?

Get help using Construct 2

Post » Mon Mar 31, 2014 7:28 am

After putting XP and Vista on a blacklist, Google is by default disabling WebGL support on these OS. Is there a way to somehow run it with parameter, like in Chrome (--ignore-gpu-blacklist) but on NodeWebkit? If yes, please describe it step by step.
B
39
S
13
G
6
Posts: 148
Reputation: 5,384

Post » Mon Mar 31, 2014 8:12 am

Not just webgl, I think all hardware acceleration, even canvas2d, is disabled.

To answer your question, sort of. Node webkit does take parameters, but for some reason the --ignore-gpu-blacklist argument isn't working in the package file currently, Ashley's looking into why. If he can get that working then C2 will automatically use it when exporting to node webkit.

Until then, your only two options that I've been able to find are:

1: make a shortcut to NW.exe, edit the properties, add " --ignore-gpu-blacklist" (everything in the quotes, but not the quotes themselves) to the end of the target field, and run that instead of the exe. Downside - this doesn't help with previewing and the user could run the exe directly.

2: revert back to an earlier version of node webkit, I think it was somewhere around version 160 that it switched over to the version with vista blacklisted. That's what I've done.
Moderator
B
94
S
33
G
33
Posts: 3,006
Reputation: 27,749

Post » Mon Mar 31, 2014 8:23 am

Message: fifallns is not yet permitted to post plain text URLS (300 rep required). 2 URLS removed. Why?
Disappointments are like road humps,
they slow you down a bit
——————————————————————————
B
2
Posts: 1
Reputation: 152

Post » Mon Mar 31, 2014 8:31 am

@Arima Thank You. Somehow I feel cheated by google. I still run Vista - I have never, ever had any problems with it... But google thinks different.
B
39
S
13
G
6
Posts: 148
Reputation: 5,384


Return to How do I....?

Who is online

Users browsing this forum: dop2000, namaewayukidesu, Yahoo [Bot] and 9 guests