How to fix blurry pixel sprites

Get help using Construct 2

Post » Thu Oct 20, 2011 4:35 pm

I'm having a similar problem. I am using dt in my movements, so the sprite movement is very imprecise. If I use Pixel Rounding, the positions of the sprites bounce back and forth since they are moving with relation to dt (not a nice whole number usually). I can't think of a way to make the sprites not blurry and without rounding. Any tips? Even in designing sprites, perhaps?

http://dl.dropbox.com/u/45336737/GentleShip/index.html
B
1
G
1
Posts: 3
Reputation: 431

Post » Thu Oct 20, 2011 4:50 pm

Is pixel rounding on in that demo you posted? It's not easy to tell, and I can't see any blurring, so I assume so. It seems to play just fine as well. It's helpful to provide your .capx so we don't have to guess your settings.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Thu Oct 20, 2011 5:01 pm

I was not using Pixel Rounding in the first link. Here's the link to the project. Thank You so much!

http://dl.dropbox.com/u/45336737/GentleShipProj/GentleShip0.1.capx

The blurring isn't fatal by any means, but if I can prevent it that'd be great.
B
1
G
1
Posts: 3
Reputation: 431

Post » Thu Oct 20, 2011 5:12 pm

If I turn on pixel rounding, it seems to work just fine. Crisp graphics and nothing "bouncing" like you say. Am I looking in the wrong place?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Thu Oct 20, 2011 5:27 pm

I'm sure you're looking at the right place. Basically with pixel rounding, since it's always moving forward, if it gets in a spot where the x is actually between pixels it will move a pixel ahead or back even if the controls aren't touched since the speed isn't exactly 1 pixel per tick. Pixel rounding is doing exactly what it's supposed to do, and the fact that you're not noticing might mean it's pretty trivial, and no one else will notice either :P . As far as I know there's no way to prevent this besides redesigning how the level moves.
B
1
G
1
Posts: 3
Reputation: 431

Post » Mon Aug 17, 2015 11:05 am

Okay, I found the answer as this is the first thing that pops up in Google search. Also note the date of my post as I'm using the most current version of C2.

1) Click to the project propriety window--
2) Mess with all the "Project" and "Configuration" settings.

After turning things on and off I got my game to load with no blur.
B
14
S
5
G
2
Posts: 164
Reputation: 2,926

Post » Tue May 10, 2016 12:35 am

I have the same problem, i am looking for objects to not blur at all at high speeds, just like Super Nintendo or Sonic games, i still can't find a solution.
B
9
S
3
Posts: 7
Reputation: 631

Post » Sun Jul 17, 2016 8:34 pm

If you go to project properties find the option sampling and set it to point that fixed it for me.
B
3
Posts: 1
Reputation: 177

Post » Mon Aug 08, 2016 10:29 pm

JustGameTV wrote:If you go to project properties find the option sampling and set it to point that fixed it for me.


Thank you sooo much! This worked for me :D
B
2
Posts: 5
Reputation: 160

Previous

Return to How do I....?

Who is online

Users browsing this forum: emoticon, makkancs and 28 guests