How to Make my Web Game Runs Smoothly at The Beginning?

Get help using Construct 2

Post » Thu Dec 25, 2014 8:58 am

I have uploaded my first ever made game using Construct 2 to my hosting.
I found out that after the loading is completed, can't interact with my menu immediately, which is just a single button to start the game. It tooks a couple of second until the button works and... the music kicks in.
From user experience point of view, I think it is not quite pleasant. Because it leads to confusion.

dapur-uang,com/games/catching-a-star-for-wulan/

So my question is...how to make it smooth?

Thanks in advance for sharing your experience and knowledge.
B
10
S
5
Posts: 220
Reputation: 1,464

Post » Thu Dec 25, 2014 9:46 am

Hard to say without looking at the .capx.
B
75
S
29
G
17
Posts: 256
Reputation: 15,250

Post » Thu Dec 25, 2014 9:58 am

www,dropboxcom/s/7lp3dvc4s3gk30s/asteroid2.capx?dl=0

@Xavier Ok, so..this the file. Please replace the coma after www.

Just for your information, the game runs ok if I test it offline.
B
10
S
5
Posts: 220
Reputation: 1,464

Post » Thu Dec 25, 2014 1:39 pm

The problem is that you have the project setting "Use loader layout" set to yes. That's why the first layout is being displayed before the project is fully loaded. Set that option to "No".
B
75
S
29
G
17
Posts: 256
Reputation: 15,250

Post » Thu Dec 25, 2014 4:09 pm

It works! Thank you.
B
10
S
5
Posts: 220
Reputation: 1,464


Return to How do I....?

Who is online

Users browsing this forum: Exabot [Bot] and 30 guests