How to solve the initial layout lag

Get help using Construct 2

Post » Sun Jul 19, 2015 9:27 am

Hi!
When the layout starts there is initial slowdown and mini freeze, in some games i see people solve it with a "screen coverer/loader" thingy but their's last for like 2 secs . but for physics (template: example physics basics) it tooks 3 seconds slowdown then the 2 seconds of freeze happen after that FPS is ~58 (on iphone 4s),
But the 5 secs per layout will not be acceptable for the player >.>
How do you guys solve it?
B
8
S
1
Posts: 14
Reputation: 492

Post » Sun Jul 19, 2015 10:06 am

I also have this problem and I want to hear the answer as much as you do!!
B
11
S
2
G
1
Posts: 84
Reputation: 852

Post » Sun Jul 19, 2015 10:50 am

You can try to hide it with a fade on the layout start
Image Image
B
25
S
14
G
139
Posts: 876
Reputation: 72,510

Post » Mon Jul 20, 2015 3:03 am

MadSpy you are a genius! XD
I will try your method also i found these two links which might be useful for others:

Plugin for layout transition:
plugin-updated-layouttransition-v1-2-layouts-transitions_t129279

Transition with code:
https://www.scirra.com/tutorials/384/sc ... ers?page=2
B
8
S
1
Posts: 14
Reputation: 492

Post » Mon Jul 20, 2015 6:39 am

Hopefully the above method will solve the problem for some of users.
But the problem i face is this:
Create new project -> 2 immovable physical objects and 2 movable physical objects.
On Galaxy note 3 there is only a little slow down (which is almost unnoticeable)
When the game layout loads on iPhone 4s for 3 seconds there is slow down (which is ok...), and after that 2 seconds of game freeze which looks very bad >.>.
-I used debugger and i noticed just after the freeze the physics engine cpu usage had a spike on one test 170+% and on another test 190+%, so somehow this must be related to physics engine?
B
8
S
1
Posts: 14
Reputation: 492


Return to How do I....?

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests