[Human Mistake, Not a Bug, Sorry]

Bugs will be moved here once resolved.

Post » Fri Jul 05, 2013 2:52 pm

Link to .capx file (required!):
[Withdrawn]

Notes:
- Sprites have a large number of animations.

Steps to reproduce:
1. Set team2 sprite to an animation lower in the list (ie. "Purple", "LightBlue", "Black")
2. Wait until a number of units have been spawned.
3. Shoot at armed units until bullets suddenly pass through (Takes a while, but usually occurs in under 20 kills)

Observed result:
- Observed with animations lower in the list ("Purple", "LightBlue", "Black").
- Has not occurred with animations higher in the list ("Blue", "Green")

Bullets will collide with the enemy sprite, but on some instances, the bullets only pass over them for some reason.
Shoots long enough, and the bullets will 'eventually' collide and destroy the target.
(Points of interest are bookmarked in the event sheet.)

Expected result:
All bullets to collide when I command them to.

Browsers affected:
Chrome: yes
Firefox: yes
Internet Explorer: yes

Operating system & service pack:
Windows 8 64-bit
Construct 2 version:
    r137 32-bitaznmonkeyboy2013-07-05 16:27:15
B
8
S
2
Posts: 40
Reputation: 2,136

Post » Fri Jul 05, 2013 3:05 pm

Your collision boxes are bad. Go have a look at EVERY single one, and you'll see some are just lines, not boxes. You can use Right-click, and either Apply to whole animation or Apply to all animations to correct.
ImageImageImage
B
71
S
20
G
202
Posts: 3,577
Reputation: 114,448

Post » Fri Jul 05, 2013 3:50 pm

How did I not see that button?!
The is embarrassing.

Thank you blackhornet for clearing this up for me.
B
8
S
2
Posts: 40
Reputation: 2,136


Return to Closed bugs

Who is online

Users browsing this forum: tarek2 and 2 guests