I have a problem with parallax alignment.

Get help using Construct 2

Post » Thu Jun 21, 2012 3:55 pm

I have a problem with parallax alignment.
if I move player to the right target works fine. but if you move left a misalignment occurs.
layer 0 - enemy0 - (parallax 100,100)
Layer 1 - enemy1 - (40.40 parallax)
camada2 - enemy2 - (15.15 parallax)
camada3 - player, target, bullet - (parallax 0.0)

Demo:
http://www.primercontrol.com.br/game1/html5/
Capx:
http://www.primercontrol.com.br/game1/estudo-paralax.rar

I've tried changing the layer of bullet but the misalignment imagepoint player.



PORT:
tenho um problema com alinhamento parallax.
se eu mover o jogador para direita minha mira funciona OK. mas se mover para esquerda acontece um desalinhamento.
camada 0 - enemy0 - (parallax 100,100)
camada 1 - enemy1 - (parallax 40,40)
camada2 - enemy2 - (parallax 15,15)
camada3 - player , mira, bullet - (parallax 0,0)

J tentei trocar a camada do bullet mas desalinha o imagepoint do player.


Obrigado
Thx

Davisdavisvasconcello2012-06-21 15:57:29
B
3
Posts: 5
Reputation: 485

Post » Thu Jun 21, 2012 4:23 pm

hmm, i dont see any problem of misalignment, the bullet is always right on target, tested in chrome,

ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Thu Jun 21, 2012 4:32 pm

but cant rotate the target on colision.

bullet on colision rotate. movo to right and see...so, move to left and see bullet follow target fine, but not rotate.
Shoot around and see target rotate while bullet is on ghost target.

i tested in chrome every.
B
3
Posts: 5
Reputation: 485

Post » Thu Jun 21, 2012 4:32 pm

Which version of Construct 2 are you using? We made a bug fix to do with parallax alignment recently.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Thu Jun 21, 2012 4:50 pm

the latest
r.95 64 bit on a Win7
r.95 32 bit on a win XP

booth have same problem.

i wrong programming file .capx ?

thx
B
3
Posts: 5
Reputation: 485

Post » Fri Jun 22, 2012 5:45 am

any help?
B
3
Posts: 5
Reputation: 485

Post » Fri Jun 22, 2012 2:13 pm

Mmm kinda tricky. SPL1 is at 171,192. When you move, it's position stays the same but it appears to move because of the parallax effect. If you move to the right then SPL1 appears to be at, say, 250,192 but to hit it you still need to shoot at 171,192.

So... I created some dummy targets on layer 3 and set their positions to the target's positions taking the parallax into account.


capx
B
54
S
28
G
18
Posts: 1,520
Reputation: 24,990

Post » Fri Jun 22, 2012 2:36 pm

I'm afraid it's a known bug, collisions don't currently take in to account parallax. So you'll need to find a way to work with all the objects on the same layer for the time being.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Fri Jun 22, 2012 3:46 pm

everything seems to be working for me, google chrome
B
10
S
2
Posts: 20
Reputation: 1,258

Post » Fri Jun 22, 2012 8:27 pm

Works Form me.
Very helpfull for me.
Thanks all for help.

B
3
Posts: 5
Reputation: 485

Next

Return to How do I....?

Who is online

Users browsing this forum: MrLOL64 and 20 guests