IE11 fps > 60 on 60 hertz monitor

Discussion and feedback on Construct 2

Post » Sun Feb 01, 2015 9:03 am

Just out of curiosity - can somebody enlighten me about, why my game runs around 67 fps when I test it in IE11 on a 60 hertz monitor (std. desktop setup Win7). Runs 60 fps in Chrome and Firefox.

Cheers,
thegrind
B
26
S
9
G
2
Posts: 78
Reputation: 2,524

Post » Sun Feb 01, 2015 9:38 am

I haven't used IE11, but maybe vsync enabled in some browsers and not others ?
Image
Game Producer & Independent Developer - http://raphaelgervaise.com
B
24
S
9
Posts: 237
Reputation: 2,232

Post » Sun Feb 01, 2015 3:31 pm

It should run at 60 FPS on a 60 Hz monitor. In fact it does on every system I've tried it on. Maybe your graphics driver needs an update.
Scirra Founder
B
398
S
236
G
88
Posts: 24,441
Reputation: 194,681

Post » Mon Feb 02, 2015 1:07 am

Just tested a little more, and my game is running well over 3600 ticks/sec in IE11. I'm running it on a newly installed Win 7 64 bit Ultimate OS. IE11 is updated and so is Win 7 (no weird addons or similar stuff). Graphics card is an old ATI HD4600 with newest driver. It has caused me zero problems for the past 4 years.

I will look more into it later today.

On a sidenote, what a great performance gain I experienced switching from old Win XP x64 Pro to Win 7 (in all browsers).
B
26
S
9
G
2
Posts: 78
Reputation: 2,524

Post » Mon Feb 02, 2015 5:55 pm

Made a clean test. C2 ran exactly 60 fps. I don't know if some of the C2 features I'm using in my game caused the anomaly. I am sure that I observed 67 fps in IE11 on at least 2 occasions - I can't replicate it every time I run the game though. I'll leave it at that.
B
26
S
9
G
2
Posts: 78
Reputation: 2,524


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 14 guests