If your object moves on its own after key release

Discussion and feedback on Construct 2

Post » Fri Oct 14, 2011 4:57 am

I figured out, at least for myself, that sometimes when the object you are controlling is suddenly moving on its own even after releasing any buttons - its because the event sheet you are working on has some ugly junk running and making the object ignore your input or lack of.

First things first, Ashley and others have mentioned this before - update your browser and gpu drivers.

After this is set, go into your event sheet and start trouble shooting by disabling events in your event sheet.

Test until you have found the culprit event that is making the object go bananas. Redo the event and make sure it structurally plays nice (or beat it into submission) with the C2 engine.

I have only had the issue whenever I test and I have an event with conditions structured in a weird way. I wish I could give an example of "weird" but it was pretty much the way things were organized and how things were being called and executed.

I have no idea if this will solve the entire issue for others, you may need to update gpu drivers or upgrade to a better gpu, redo events, update browser and make sure your problem isn't between the chair and the keyboard, I just know it has helped me and so far so good - I have had no crashes or any weird object movements.ViLe2011-10-14 05:07:14
B
16
S
2
G
1
Posts: 20
Reputation: 1,284

Post » Fri Oct 14, 2011 5:07 am

That didn't help my problem. Thanks for posting though. My spec is:

OS: Windows XP SP3
Browser: Google Chrome [Latest]
GPU: ATI Radeon Sapphire HD 4850 1 GB
RAM: 4.0 GB
CPU: Intel Core i3 2.8GHz

This problem happened to me everytime when I put the 8 Direction behavior.
B
12
S
5
G
5
Posts: 80
Reputation: 3,572

Post » Fri Oct 14, 2011 5:10 am

Is it only when you apply the behavior to an object or are you creating custom controls in your event sheet to move the object?

Post your cap and keep an object with 8-directional behavior.ViLe2011-10-14 05:11:05
B
16
S
2
G
1
Posts: 20
Reputation: 1,284

Post » Fri Oct 14, 2011 5:27 am

it happened everytime when I have applied 8 Directional behavior to an object. For example the Ghost Shooter game.
B
12
S
5
G
5
Posts: 80
Reputation: 3,572

Post » Fri Oct 14, 2011 12:46 pm

I believe it's a bug with Google Chrome specifically, and isn't an issue with any other browsers. Can you reproduce the problem on anything other than Chrome?

If it's a Chrome bug, there's nothing that can be done really, except hope they fix it in a future version.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,468

Post » Fri Oct 14, 2011 1:03 pm

ya it's not Construct 2 Bug. It runs fine on Safari and Firefox.
B
12
S
5
G
5
Posts: 80
Reputation: 3,572


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 7 guests