Ignore webGL shader effect in editor?

Get help using Construct 2

Post » Wed Jan 30, 2013 4:42 am

This might be a really stupid question, but I can't find any record of it being asked before.

I applied a webGL shader to my layer, but now I can't see anything properly in the editor!

Is there a way to ignore shaders in the editor? I'm applying a bulge effect to my main layer and the effect means that now when selecting a sprite I actually have to click about 20 pixels away from where it actually is. It's a little confusing.
B
24
S
4
G
1
Posts: 244
Reputation: 3,462

Post » Wed Jan 30, 2013 8:09 am

Turn the "amount" of bulge to 0 while editing stuff. I'm not sure if bulge actually has that but I'm guessing it does.
B
43
S
12
G
7
Posts: 603
Reputation: 7,761

Post » Wed Jan 30, 2013 1:21 pm

I've been meaning to add an enable/disable shader preview option, but in the mean time just turn WebGL off in project properties and the editor updates accordingly.
Scirra Founder
B
367
S
217
G
82
Posts: 23,262
Reputation: 183,679

Post » Wed Jan 30, 2013 5:08 pm

Oh brilliant, I'll give that a shot. Thanks Ashley.
B
24
S
4
G
1
Posts: 244
Reputation: 3,462

Post » Tue Dec 10, 2013 4:48 pm

Is there an update on that "enable/disable effects" feature you were talking about, Ashley?

I mean, turning off WebGL did the trick, but I was hoping for something that would turn off effects only in the editor.
B
14
S
4
Posts: 75
Reputation: 1,095

Post » Sun Dec 04, 2016 12:04 pm

Ashley wrote:I've been meaning to add an enable/disable shader preview option, but in the mean time just turn WebGL off in project properties and the editor updates accordingly.

Any updates on this?
B
37
S
11
G
10
Posts: 976
Reputation: 8,955

Post » Sun Dec 04, 2016 12:44 pm

@Zebbi

https://www.scirra.com/manual/66/projects


The properties for a project can be edited in the Properties Bar after selecting the name of the project in the Project Bar, or using the Project Properties shortcut in Layout Properties.

Preview effects
Whether or not to display effects and blend modes in the Layout View. If enabled, WebGL must also be enabled for the effects to appear. If disabled, WebGL effects are not rendered in the editor, and all objects are drawn as if they have Normal blend mode.
B
23
S
3
G
1
Posts: 407
Reputation: 2,052


Return to How do I....?

Who is online

Users browsing this forum: 99Instances2Go, UncleHo74 and 1 guest