im a Noob who can't get the platformer right

For questions about using Classic.

Post » Sun Feb 19, 2012 9:45 pm

Help, I've been on this for 3 days and can't get it right. It's driving me nuts!

cap file


Issue 1: Why on title screen, when I press enter, it skips to the level 1 layout and not main menu Layout? What did I do wrong?

Issue 2: Why is my player movement wrong? When landing from a jump/fall, it doesn't automatically go to Idle animation. In fact, it cannot decide whether to go to Idle or Fall or Walking. I tried everything explained in Easy Platform Movement in Construct except the hitbox part. because when i import hitbox it messed up my animation even worse. so i use custom hitbox to get the hitboxes right.

and i can't find any good explanation about hotspots and image point. I tried editing the hotspots for my sprite and it just makes it worse.

please, please lend me a help here. You'd save a guy who's in the brink of insanity.

B
6
Posts: 7
Reputation: 430

Post » Mon Feb 20, 2012 12:25 am

"cap file"

link doesn't seem to work.
B
6
S
2
G
5
Posts: 249
Reputation: 2,323

Post » Mon Feb 20, 2012 3:21 am

Sorry for the mess...

http://www.mediafire.com/?crs4hyzac6cy4ru
Huzairi G2012-02-20 03:22:17
B
6
Posts: 7
Reputation: 430

Post » Mon Feb 20, 2012 4:35 pm

Make a delay, before you change to the next layout.
On any key -> wait (delay 150ms) -> go to layout X.

Because with "enter" you also pressed enter for the next condition, which is gamemode and then again, the next enter for game entry. Put a delay before you go to the next layout, if the next layout has also an "enter" condition.

For your animation problem, it might be bad, that you have so many different collision masks(height is different) and it can't choose when the player is landing, because then the collision mask updates and is smaller/greater...etc.
Maybe someone else could look into it. If someone fixes the "copy collision mask to each frame" - bug, then I had a solution. But for now, maybe try to stay with 1 collision height.zyblade2012-02-20 16:48:35
B
24
S
9
G
2
Posts: 294
Reputation: 3,160

Post » Tue Feb 21, 2012 3:16 am

Thank you zyblade.

For (1), after I put the 150ms delay as a sub-event in title screen layout, then go to the next layout (Main Menu), it worked. But for the "Main Menu" layout, the same trick doesn't work. For some reason, pressing enter does not do anything. So i disabled it for the time being.

For (2), I tried editing all the collision mask to use the same height and width, except for walking animation. As the problem lies with falling and idle continuously rotating with each other, i fixed those first. But it didn't work.

It was not later until I edited the hotspot for the falling animation's frames, by increasing the Y value up to 3~6 pixels. So the real problem is the hotspot. I totally need to look up on hotspots more, but there seems to be very little discussion or documentation involving hotspot function, aside from what I found in deadeye's platform school tutorial.
B
6
Posts: 7
Reputation: 430

Post » Tue Feb 21, 2012 9:18 am

Maybe make the menu with "enter" and no delay, but instead, you make a global var, if you press enter, the global var switching to 1 for a few milli seconds, and then back. Put a condition whenever you press enter, the global var has to be 0.
Method without global var:
When the "enter" key is released -> go to next layout. Will that work?
Can't try it out, since I'm at work right now :P.
B
24
S
9
G
2
Posts: 294
Reputation: 3,160


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 0 guests