Image Files Werent saved by Construct.

Bugs will be moved here once resolved.

Post » Wed Sep 07, 2011 2:42 am

Hey there C2 People!
Cen Silver in the area taking the chance to report some major buggy issues:

Major bug (BUG 1)

Working in my first Project, then ran it.

Condition: FileExists(disk_path)
File: HttpFileServer.cpp
Line: 278
Function: void __thiscall HttpFileServer::ServerRespond(struct _HTTP_REQUEST_V2 *)
Build: release 54 (32-bit) checked
Component: HTML5 exporter
(Last Win32 error: 2)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Anull   Repeat   Ignore   
---------------------------

After saving, closing, and reopening the project, the construct window reported this bug:

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Cannot find project file for animation frame

Condition: FileExists(GetProjectPath().c_str())
File: Projects\AnimationFrame.cpp
Line: 186
Function: void __thiscall AnimationFrame::Load(const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)
Build: release 54 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 2)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Anull   Repetat   Ignore   
---------------------------

and then followed (Around 4)image errors like this one:

---------------------------
Failed to load texture
---------------------------
Error loading texture 'H:\Project Silver BUGGED\Animations\Enemy\Default\000.png': Failed to read image file data
This may indicate a corrupt PNG file in the project directory. The image will not be able to be displayed in the editor.
---------------------------
OK   
---------------------------

Unfortunate it's late here and i got important stuff to do now, so i can't confirm, but it seemed as the images that gave that bug where the same as the images that had transparency gradients.

All my images are saved as *.png

I have no clue on my system specs other than "Windows 7 x32-Bits"

It's not a persistent error, since i reloaded the problematic images and then resaved, and after that the bug didn't appear anymore.

It seems to have caused a problematic and sticky issue in my project tough, but i'm not sure, so i'll redo it from scratch first to check.

I would pass you the issued file like asked priorly, but i have no clue how should i do this here. Since it's the only thing you guys (Ashley? :P) didn't explain how to do in the "How to" section. so please explain to me how do i do it and i'll be more than heppy to hand you the file.

Well, i think i've covered it all, but for the sake of archival purposes, please tell me if error messages alone help you people, because i got two more of them duely saved, but can't seem to remember how they where caused... (My phail... ).

Well, i think that's all. Good night everyone.
B
4
G
1
Posts: 39
Reputation: 690

Post » Wed Sep 07, 2011 5:38 am

Hi CenSilver.

You can provide files on dropbox

As for your project, if this is a problem about images, copy the fixed images to the Animations\Object_name folder in your project's base folder.
If it is a capx, open it in winzip and navigate to the same folder.

Capx is basicly a zip file containing the structure of your project.

This might save the projects.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,999
Reputation: 57,793

Post » Wed Sep 07, 2011 5:59 pm

No it's not, The problem is about an innacurate axis (hotspot), the images aren't spawning where they should.

And oh yeah, i already got dropbox because i already saw it was needed, my problem's not that, but how do i pass you the link to the project folder, cause the only way i found how to do this was by giving it the e-mail of the person i want to share the folder with...

And aside from that axis... uh... "glitch", My project is restored already. thanks.
B
4
G
1
Posts: 39
Reputation: 690

Post » Wed Sep 07, 2011 6:02 pm

PS: I know about the hotspot tool and tried it already, and it's in the center of the image alright, only ingame the glitch shows itself.
B
4
G
1
Posts: 39
Reputation: 690

Post » Wed Sep 07, 2011 6:14 pm

You don't need to share a whole folder, only the file. If your trying to share a folder project, please use something like winzip to compress it and make it a single file. It will be easier to share.

If you have installed the application on window go in the drop box folder on your PC (access it by right clicking the tray icon "Open dropbox folder" or something like that (I have a translated version)).
Once you found the .capx file you want to share right click on it => dropbox, copy public link to clipboard.
And this is the link you post on the forum.

If you have uploaded the files in dropbox's webpage, navigate to your file, select it, click the green arrow on the right and click copy public link.

For sharing to work, you need to upload your file inside of the public default folder. (dropbox_base_folder\public\)

The hotspots are setted in the .caproj file (which is a xml type file you can open in the notepad) in the element <frame duration>

ex:
[code]<frame duration="1" hotspotX="0.5" hotspotY="0.5" />[/code]
The element frame duration is a child of the element <animation>.

Anyway, you should now be able to post files from dropbox.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,999
Reputation: 57,793

Post » Wed Sep 07, 2011 7:28 pm

Thank you very much! Here's the file:

http://dl.dropbox.com/u/40683395/Project%20Silver%20BUGGED/One%20File%20Source/Silver%20Project.capx
B
4
G
1
Posts: 39
Reputation: 690

Post » Wed Sep 07, 2011 7:29 pm

(I didn't know they had to be in the public folder, that's why i didn't find how to share them... )
B
4
G
1
Posts: 39
Reputation: 690

Post » Wed Sep 07, 2011 7:46 pm

Is that better ?
I didn't see truely glitch. Just the explosion object being spawned a little too much on the left, compared to the ennemy position.
I fixed it in the bullet object by setting the hotspot to the right.

Is that what was bugging you ? Else I saw no other glitch as about spawning.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,999
Reputation: 57,793

Post » Wed Sep 07, 2011 8:06 pm

Negative. The explosion is like that because it's supposed to appear at the impact point of the bullet, instead of the center of the enemy.

The bug is at the bullet itself, it's supposed to come out at the tip of player's arm.

however it's coming out a few pixels lower... (Upper, when mirrored)

Funny thing? in the file you just passed me, the bullet is now coming out at the correct height. however, its trail is not.

Can you fix this?
B
4
G
1
Posts: 39
Reputation: 690

Post » Wed Sep 07, 2011 8:14 pm

New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,999
Reputation: 57,793

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests