Image point crazyness :/

Get help using Construct 2

Post » Fri Aug 22, 2014 11:40 pm

Hi guys... I am becoming crazy... I set a image point from where to spawn a bullet...
it works for 1 second...as soon my player goes arround ( i press the arrows) the bullet is spawned from another point....I checked really all frames of all animations....nothing...no change.

Other thing: I place as Zorder the player at first on the top...the bullet underbead the player as zorder...still the bullet is coming out from the top of the players layer...??? helpppp :/


thanks guys
B
37
S
16
G
2
Posts: 447
Reputation: 4,860

Post » Sat Aug 23, 2014 1:32 am

Without seeing the .capx or at least a screenshot of your code there isn't really any way for us to figure out where your imagepoint issue is coming from. For the Z order issue, it sounds like you're setting the order in the layout rather than when the bullet is created, because all objects are created on top by default. Your event for creating it should also set the order you want. Bullet / Move to Object / Player and set it to behind. If you're already doing that and it still isn't working, try doing it every tick instead of on created.
Last edited by Ahr Ech on Sat Aug 23, 2014 3:04 am, edited 1 time in total.
B
32
S
9
G
4
Posts: 198
Reputation: 5,079

Post » Sat Aug 23, 2014 1:56 am

For Z order, set On Created (Bullet) = Set to behind player

Image point works just fine, there's definitely a code issue and you just have to go over it again carefully.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Sat Aug 23, 2014 7:05 am

thanks guys...I will try :)...probably I am simply a newcomer...
B
37
S
16
G
2
Posts: 447
Reputation: 4,860


Return to How do I....?

Who is online

Users browsing this forum: totoe, wizdigitech and 14 guests