Images look stretched down in the editor!

Bugs will be moved here once resolved.

Post » Thu Dec 14, 2017 5:21 pm

Problem Description
____Images look stretched down in the editor but are actually fine in the image editor or when previewing.
It's happened with older projects, as well as every new project. most already-imported images are fine, but some and every new image does the same.
____

Attach a Capx
____ https://lolindirlink.stackstorage.com/s/LVvXeMIELanLo82 ____

Description of Capx
____ It's just a blank project with 1 image inserted. ____
here's a screenshot of the problem: (a preview window with the correct size showing is also open at the right side)
notice how the image formats seem to be correct. it's just a display bug in the editor. the actual image is fine!
Editing is just horrible this way.
Image

Steps to Reproduce Bug
  • open Construct 2, import sprite (no matter how)

Observed Result
____ The image gets imported but it LOOKS stretched down in the editor. it's actually fine when editing or previewing. ____

Expected Result
____ the image to be the right size in the editor. ____

Affected Browsers
    -nothing to do with the browsers-
  • Chrome: (YES/NO)
  • FireFox: (YES/NO)
  • Internet Explorer: (YES/NO)

Operating System and Service Pack
____ Windows10 -up to date ____

Construct 2 Version ID
____ both 245 and 250 had the problem____
~LL

"90 Degrees" powered by C2 on Google Play: https://play.google.com/store/apps/deta ... etyDegrees
B
60
S
13
G
1
Posts: 28
Reputation: 4,854

Post » Thu Dec 14, 2017 6:12 pm

Edit: added a Capx
~LL

"90 Degrees" powered by C2 on Google Play: https://play.google.com/store/apps/deta ... etyDegrees
B
60
S
13
G
1
Posts: 28
Reputation: 4,854

Post » Thu Dec 14, 2017 7:13 pm

Looks correct for me. In the past this has always been a graphics driver bug. Try updating your drivers.
Scirra Founder
B
406
S
240
G
91
Posts: 24,771
Reputation: 197,558

Post » Fri Dec 15, 2017 4:00 pm

The weird thing is, this was never a problem. Just recently (and nothing changed in the meantime) most of the older images are unaffected. But every newly imported ones are.
The graphics drivers are fully up to date, I tried reverting back but also no effect on the problem.
No idea how to pinpoint the cause further.. can't continue working visually like this.
Help! :/
~LL

"90 Degrees" powered by C2 on Google Play: https://play.google.com/store/apps/deta ... etyDegrees
B
60
S
13
G
1
Posts: 28
Reputation: 4,854


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests