Include Event Sheet = Won't Start Game

Bugs will be moved here once resolved.

Post » Tue Jun 26, 2012 11:33 am

Sorry about this, should be fixed in the next build now, it was a straightforward solution. A great deal of the runtime was refactored since the last build for the javascript minifying optimisation (see the performance note in r96), and one of the code changes accidentally broke includes. Luckily it's just a beta release - this is why we call them beta!
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Tue Jun 26, 2012 12:10 pm

I'm just glad it was found! Thanks for the update!
B
58
S
20
G
7
Posts: 305
Reputation: 8,804

Post » Tue Jun 26, 2012 6:34 pm

Glad to hear this will be getting addressed soon. In the meantime, however, how do I 'downgrade' my project to run in R95 again? The file for the project seems to have locked itself to the R96 version, where I can't play it.
B
10
S
1
Posts: 38
Reputation: 1,964

Post » Tue Jun 26, 2012 8:43 pm

@CAWithey - you need to make sure you backup projects before upgrading to a beta release, because you generally can't downgrade projects after saving them (unless you edit the XML, and have not used any new features specific to that build). Did you turn on Construct 2's automatic backup?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Tue Jun 26, 2012 8:54 pm

No, I've saved it too many times since then. Nice thought, but unfortunately this newest release has made testing impossible, and therefore slows progress considerably until a fix is released. Ironic, as the only reason I had to upgrade at all was to upload the game for the first time to the Scirra online arcade. Elsewise, I would not have bothered with the beta version (The arcade did not accept the R95 version).

Thanks for the quick response.
B
10
S
1
Posts: 38
Reputation: 1,964

Post » Fri Nov 16, 2012 10:10 pm

Got the same problem here.
I had to upgrade from the latest stable [108.2] to 109 beta in order to publish (This seems weird to me). This introduced a couple of bugs (see bug reports on 109).
I have automatic backup turned on, but the backup file is 109 beta as well and can't be opened in 108.2. I've made backups along the way, but it would require significant time to get it back into a state where it is now.
Any suggestions? When is the next stable version expected?
B
3
Posts: 4
Reputation: 726

Post » Sat Nov 17, 2012 12:57 am

@wildmoos - looks like the original issue in this thread was fixed back in June. You might want to post a new thread in the Bugs forum with a .capx reproducing the issue.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Sat Nov 17, 2012 3:20 am

Thanks for the quick reply :)
I was able to get up and running again and resubmitted my game.

Not really a bug, but I do think that you should not have to update to the latest beta version in order to publish (only to the latest stable version perhaps).
B
3
Posts: 4
Reputation: 726

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests