inconsistence in feedback screens

Discussion and feedback on Construct 2

Post » Wed Jun 07, 2017 8:52 pm

Needing some help. I have a game in which I have questions that need to be answered.
These are graphs on which students need to read data and then click on dots to show the points on the graph.
The dot sprite has an instance variable and I assigned the instance to each dot on the graph.
I have a variable (answer) that increments to count the number of correct dots. Then when all the correct dots have been filed and the answer = 5, I have a feedback screen that tell them "good job".
If they choose a wrong dot, they get the feedback "incorrect" even if answer<5.
I have the same code to check each question. However the feedback screen appears only for the first question even when their answer is correct. This is driving me crazy.
I use tweenLite to move the feedback screens in an out. I do not believe this is where the problem is since it works for the first question.
Since there are 5 dots that are correct, I check if answer= 5 and then get the "good job" feedback. There are several things happening at the some time and only the feedback screen is the one that does not work on the other questions whether it is for the correct dots or the incorrect dots.
Any idea?

Note sure why the dropbox link is not working.
Image

Here is the same as URL
https://www.dropbox.com/s/rkngd96dihsceju/feedback.png?dl=0
B
8
S
1
Posts: 86
Reputation: 618

Return to Construct 2 General

Who is online

Users browsing this forum: Palnix777 and 12 guests