Incorrect encoding in the browser Mozilla (AJAX)

Bugs will be moved here once resolved.

Post » Tue Feb 09, 2016 2:22 pm

Problem Description
When you request through AJAX browser Mozilla encoding parameter is changed to text cp1251. In this coding lacks many of the characters that is causing problems. In other browsers utf8.


Steps to Reproduce Bug
  • Use GET method
  • Юрий >> Þðèé

Affected Browsers
  • Mozilla: (YES)
  • Another: (NO)
  • Internet Explorer: (Not tested)

Operating System and Service Pack
Win7 sp1 64bit

Construct 2 Version ID
r220

Sorry for Google Translate
B
18
S
2
Posts: 24
Reputation: 888

Post » Tue Feb 09, 2016 2:44 pm

try ...->AJAX|Override MIME type with "text/plain; charset=utf-8" before you call an AJAX Request.
B
23
S
3
G
1
Posts: 411
Reputation: 2,060

Post » Tue Feb 09, 2016 4:07 pm

Asmodean wrote:try ...->AJAX|Override MIME type with "text/plain; charset=utf-8" before you call an AJAX Request.

Did not help
B
18
S
2
Posts: 24
Reputation: 888

Post » Tue Feb 09, 2016 5:27 pm

Construct 2 does not change the encoding, unless you use the "Override MIME type" action. So it seems most likely the server is sending the wrong encoding itself, which is very common, or that Firefox is doing something differently. Either way as per our bug report guidelines, if you do not provide us with a way to investigate there is nothing we can do, so closing.
Scirra Founder
B
378
S
219
G
84
Posts: 23,854
Reputation: 187,841


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests