infinite scrolling

For questions about using Classic.

Post » Sun Jan 11, 2009 1:50 am

I've uploaded a new version, with new graphics, and simplified code.

[url:34yl9q97]http://www.mukpuddy.com/timtests/mukbuggy_level1_test.cap[/url:34yl9q97]

The scrolling issue is still there, but it's not as bad. It's a little smoother now that I moved the wheels aswell, as opposed to letting them reset to the right position automatically.

It seems like the physics interferes with the move, is it possible to disable the physics when you hit the edge, then enable them again?

Strange thing is, it worked great when it was just a ball. As soon as switched to the car it went bung.
B
9
S
4
G
5
Posts: 136
Reputation: 2,952

Post » Sun Jan 11, 2009 2:38 am

Huh, that's strange. I didn't think that the physics would have any adverse reaction to that. :?

Unfortunately there's no way to disable the physics(I don't know why, considering all the other behaviors have that option. Probably something to do with Box2D), but I managed to fix it by saving the X velocity, Y velocity, angular velocity, angle, X and Y positions of the car, and the angular velocities of the wheels everytime it goes off the side, then it will destroy those, create new ones, reestablish the hinges, set the angle, the Y position, the new X position, and then finally restoring all of the motion. Here's the modified CAP in case that wasn't explained very well: Modified driving CAP

By the way, nice graphics you have there. :)
Moderator
B
97
S
36
G
19
Posts: 1,584
Reputation: 17,692

Post » Sun Jan 11, 2009 3:12 am

Wow, nice work. Thanks a bunch!

I've adjusted the background bits so it's not flicking.

[url:3uat3gjl]http://www.mukpuddy.com/timtests/mukbuggy_level1_test.cap[/url:3uat3gjl]

Seems to work sweet. Just the tiniest little flicker on the bg, not sure what's causing that, just the sudden camera move i guess. I don't think it's a problem though. Especially if the background is bigger so it doesn't happen as often.

Thanks for the kind words on the graphics, I've still got a few tweaks to do before I'm totally happy, that highlight on the wheel looks retarded, plus there will be a driver.
B
9
S
4
G
5
Posts: 136
Reputation: 2,952

Post » Sun Jan 11, 2009 4:09 am

the torque is a lot of fun to play with
B
2
S
2
G
5
Posts: 293
Reputation: 2,236

Post » Sun Jan 11, 2009 8:16 pm

The torque is a lot fun to play with. Especially when you add a huge ramp.

Btw, I've never seen the custom collision mask used. That's pretty cool.
B
3
S
2
G
4
Posts: 271
Reputation: 2,017

Post » Mon Jan 12, 2009 8:29 am

[quote:11531wfo]The torque is a lot fun to play with[/quote:11531wfo]

I thought so too. I'll have to make a proper track, that's bigger.

A big part of the concept is the vertical scale, which is in no way captured here. I need to do this on my next run through.

The collision thing is the best way I could come up with to put one collision mask on multiple background tiles. Seems to work. It did a couple of strange things at first, like wierd areas where you suddenly dropped. But I just redrew the mask a few times until it came right.

Now onto making it an actual game, instead of just a car going back and forth.
B
9
S
4
G
5
Posts: 136
Reputation: 2,952

Post » Wed Jan 14, 2009 6:00 pm

[quote="Squeemish":137komoq]like wierd areas where you suddenly dropped.[/quote:137komoq]
Yeah that happened to me when I tried redrawing the track. It was like the car found a small hole and just slipped right through. Is that a Construct bug?
B
3
S
2
G
4
Posts: 271
Reputation: 2,017

Post » Thu Jan 15, 2009 5:39 am

Seems to be happening a lot for me now that I've changed the track. Can't get it right.

I assume it's a bug with construct. Unless I've done something dumb.
B
9
S
4
G
5
Posts: 136
Reputation: 2,952

Post » Thu Jan 15, 2009 3:54 pm

Did you bug report it? I don't currently have a .cap that exhibits the problem.

As a workaround you can always try patching the holes with solid blocks.
B
3
S
2
G
4
Posts: 271
Reputation: 2,017

Previous

Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 4 guests