Intel XDK Build error

Discussion and feedback on Construct 2

Post » Tue Jun 28, 2016 2:55 am

yesterday was not happening :/

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all dependencies for configuration ':_armv7DebugCompile'.
> Could not find com.google.android.gms:play-services-games:9.0.2.
Searched in the following locations:
https://repo1.maven.org/maven2/com/goog ... -9.0.2.pom
https://repo1.maven.org/maven2/com/goog ... -9.0.2.jar
https://download.01.org/crosswalk/relea ... -9.0.2.pom
https://download.01.org/crosswalk/relea ... -9.0.2.jar
file:.../android-sdk/extras/android/m2repository/com/google/android/gms/play-services-games/9.0.2/play-services-games-9.0.2.pom
file:.../android-sdk/extras/android/m2repository/com/google/android/gms/play-services-games/9.0.2/play-services-games-9.0.2.jar
file:.../android-sdk/extras/google/m2repository/com/google/android/gms/play-services-games/9.0.2/play-services-games-9.0.2.pom
file:.../android-sdk/extras/google/m2repository/com/google/android/gms/play-services-games/9.0.2/play-services-games-9.0.2.jar
Required by:
:android:unspecified
> Could not find com.google.android.gms:play-services-plus:9.0.2.
Searched in the following locations:
https://repo1.maven.org/maven2/com/goog ... -9.0.2.pom
https://repo1.maven.org/maven2/com/goog ... -9.0.2.jar
https://download.01.org/crosswalk/relea ... -9.0.2.pom
https://download.01.org/crosswalk/relea ... -9.0.2.jar
file:.../android-sdk/extras/android/m2repository/com/google/android/gms/play-services-plus/9.0.2/play-services-plus-9.0.2.pom
file:.../android-sdk/extras/android/m2repository/com/google/android/gms/play-services-plus/9.0.2/play-services-plus-9.0.2.jar
file:.../android-sdk/extras/google/m2repository/com/google/android/gms/play-services-plus/9.0.2/play-services-plus-9.0.2.pom
file:.../android-sdk/extras/google/m2repository/com/google/android/gms/play-services-plus/9.0.2/play-services-plus-9.0.2.jar
Required by:
:android:unspecified
> Could not find com.google.android.gms:play-services-ads:9.0.2.
Searched in the following locations:
https://repo1.maven.org/maven2/com/goog ... -9.0.2.pom
https://repo1.maven.org/maven2/com/goog ... -9.0.2.jar
https://download.01.org/crosswalk/relea ... -9.0.2.pom
https://download.01.org/crosswalk/relea ... -9.0.2.jar
file:.../android-sdk/extras/android/m2repository/com/google/android/gms/play-services-ads/9.0.2/play-services-ads-9.0.2.pom
file:.../android-sdk/extras/android/m2repository/com/google/android/gms/play-services-ads/9.0.2/play-services-ads-9.0.2.jar
file:.../android-sdk/extras/google/m2repository/com/google/android/gms/play-services-ads/9.0.2/play-services-ads-9.0.2.pom
file:.../android-sdk/extras/google/m2repository/com/google/android/gms/play-services-ads/9.0.2/play-services-ads-9.0.2.jar
Required by:
:android:unspecified
Hi I am Samuel :)

My google play
B
42
S
10
G
1
Posts: 126
Reputation: 3,278

Post » Tue Jun 28, 2016 10:19 am

1 Are you using xdk last update? 2 Are you using plugins?
B
19
S
6
G
2
Posts: 260
Reputation: 2,653

Post » Tue Jun 28, 2016 10:45 am

Josek5494 wrote:1 Are you using xdk last update? 2 Are you using plugins?


Yes, no have more updates for download.

Yes have admob plugin.
Hi I am Samuel :)

My google play
B
42
S
10
G
1
Posts: 126
Reputation: 3,278

Post » Tue Jun 28, 2016 11:00 am

martdsam wrote:
Yes, no have more updates for download.

Yes have admob plugin.


Your error is coming from a google services library which i think is deprecated or bad hosted. Maybe the admob plugin is the problem.
Be sure you have this line in the additions file in xdk if you're using official C2 admob plugin:
Code: Select all
<intelxdk:plugin intelxdk:name="https://github.com/cranberrygame/cordova-plugin-ad-admob" intelxdk:value="https://github.com/cranberrygame/cordova-plugin-ad-admob" />


If that doesn't work, try with one of these two admob c2 plugins instead:

https://www.youtube.com/watch?v=i_-SaQplAxY (Totally free)

https://www.youtube.com/watch?v=dnyziNpxNOI (2% ads traffic redirected for cordova developers, not for me)
B
19
S
6
G
2
Posts: 260
Reputation: 2,653

Post » Tue Jun 28, 2016 11:34 am

Cranberry made changes which kinda of broken things, because this plugin was working before he mentioned that he was going to "update" the plugin this past weekend, so I guess I'll be using the plugins Josek posted here.
Image
B
82
S
16
G
4
Posts: 503
Reputation: 8,978

Post » Tue Jun 28, 2016 11:38 am

KazaaMafia wrote:Cranberry made changes which kinda of broken things, because this plugin was working before he mentioned that he was going to "update" the plugin this past weekend, so I guess I'll be using the plugins Josek posted here.


Thank you ^^ Please consider donating to keep me doing what i do!

Here's my blog where i post free and useful code and plugins: https://hermitsdevelopment.blogspot.com.es/
B
19
S
6
G
2
Posts: 260
Reputation: 2,653

Post » Wed Jun 29, 2016 12:01 am

Josek5494 wrote:
martdsam wrote:
Yes, no have more updates for download.

Yes have admob plugin.


Your error is coming from a google services library which i think is deprecated or bad hosted. Maybe the admob plugin is the problem.
Be sure you have this line in the additions file in xdk if you're using official C2 admob plugin:
Code: Select all
<intelxdk:plugin intelxdk:name="https://github.com/cranberrygame/cordova-plugin-ad-admob" intelxdk:value="https://github.com/cranberrygame/cordova-plugin-ad-admob" />


If that doesn't work, try with one of these two admob c2 plugins instead:

https://www.youtube.com/watch?v=i_-SaQplAxY (Totally free)

https://www.youtube.com/watch?v=dnyziNpxNOI (2% ads traffic redirected for cordova developers, not for me)


I try cocoon.io and work, thankyou so much :D
Hi I am Samuel :)

My google play
B
42
S
10
G
1
Posts: 126
Reputation: 3,278

Post » Wed Jun 29, 2016 9:41 am

martdsam wrote:
Josek5494 wrote:
martdsam wrote:
Yes, no have more updates for download.

Yes have admob plugin.


Your error is coming from a google services library which i think is deprecated or bad hosted. Maybe the admob plugin is the problem.
Be sure you have this line in the additions file in xdk if you're using official C2 admob plugin:
Code: Select all
<intelxdk:plugin intelxdk:name="https://github.com/cranberrygame/cordova-plugin-ad-admob" intelxdk:value="https://github.com/cranberrygame/cordova-plugin-ad-admob" />


If that doesn't work, try with one of these two admob c2 plugins instead:

https://www.youtube.com/watch?v=i_-SaQplAxY (Totally free)

https://www.youtube.com/watch?v=dnyziNpxNOI (2% ads traffic redirected for cordova developers, not for me)


I try cocoon.io and work, thankyou so much :D


Lol i didn't know my plugins works with cocoon hahahaha Thanks for your test!
B
19
S
6
G
2
Posts: 260
Reputation: 2,653

Post » Wed Jun 29, 2016 11:08 am

Josek5494 wrote:Lol i didn't know my plugins works with cocoon hahahaha Thanks for your test!


Not with the plugin, I use native construct ad plugin. Sorry for the misunderstanding ><
Hi I am Samuel :)

My google play
B
42
S
10
G
1
Posts: 126
Reputation: 3,278

Post » Wed Jun 29, 2016 1:32 pm

martdsam wrote:
Josek5494 wrote:Lol i didn't know my plugins works with cocoon hahahaha Thanks for your test!


Not with the plugin, I use native construct ad plugin. Sorry for the misunderstanding ><


hahaha no problem ^^
B
19
S
6
G
2
Posts: 260
Reputation: 2,653


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests