Internet Explorer 10 - Audio & WebGL Not Working?

Get help using Construct 2

Post » Fri Feb 15, 2013 5:39 pm

Internet Explorer 10 - Audio & WebGL Not Working?

Hi,

My "Construct 2" game has no audio or WebGL
in Windows 8 Internet Explorer 10 ?

How do I fix the above two problems?
Thanks!

Click here to play the game!

JeZ+Lee
B
11
S
3
G
4
Posts: 105
Reputation: 2,950

Post » Fri Feb 15, 2013 5:41 pm

WebGL is not supported by Internet Explorer, and not sure what the issue is regarding audio without a capx, but playback rate often causes weird issues in IE.
Moderator
B
72
S
13
G
11
Posts: 900
Reputation: 11,783

Post » Fri Feb 15, 2013 5:42 pm

Web GL is not supported on Internet explorer. You also have to use certian audio formats for windows as well... there are some articles floating around on it, I got this from a search on the site here using "Internet Explorer" + WebGL: http://www.scirra.com/forum/microsoft-declares-webgl-harmful-to-security_topic43124.html

Search is your freind...
B
49
S
11
G
10
Posts: 1,833
Reputation: 14,413

Post » Fri Feb 15, 2013 5:50 pm

[QUOTE=thehen] WebGL is not supported by Internet Explorer, and not sure what the issue is regarding audio without a capx, but playback rate often causes weird issues in IE.[/QUOTE]Hi,

Here is the capx file:
http://16bitsoft.com/V2/Files/RocksInSpace_Alpha4/RocksInSpace_Alpha4.capx

That sucks that Microsoft does not support WebGL.
Hope we can get the audio working though in IE10

Thanks!

JeZ+Lee
B
11
S
3
G
4
Posts: 105
Reputation: 2,950

Post » Fri Feb 15, 2013 7:17 pm

[quote=Scirra Blog]We are disappointed to see IE10 still does not support the free Vorbis audio codec, either in Ogg or a WebM container.[/quote]

Source: IE10 review: still disappointing for HTML5 gamesNimtrix2013-02-15 19:18:50
B
27
S
8
G
8
Posts: 903
Reputation: 8,452

Post » Fri Feb 15, 2013 8:45 pm

[QUOTE=Nimtrix] [quote=Scirra Blog]We are disappointed to see IE10 still does not support the free Vorbis audio codec, either in Ogg or a WebM container.[/quote]

Source: IE10 review: still disappointing for HTML5 games[/QUOTE]Hi,

This is rather frustrating.
I made an HTML5/JS game from the ground up and the audio worked on IE10.
Why can't "Construct 2" audio work on IE10??

JeZ+Lee
B
11
S
3
G
4
Posts: 105
Reputation: 2,950

Post » Fri Feb 15, 2013 8:49 pm

Well , We need to live with it :(

Chrome and Firefox are good alternatives to IE ,
We shall survive with those

Cheers
B
34
S
16
G
16
Posts: 2,222
Reputation: 16,564

Post » Fri Feb 15, 2013 9:00 pm

AAC is supposed to work with IE.
I don't have IE 10 so I can't test your capx with this one, but the sound/music did work in IE9.

Check for errors in your browser and see if it raises errors that might explain why audio is malfunctioning.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,786

Post » Sat Feb 16, 2013 11:11 am

Audio is supposed to work on IE10, and indeed it has in the past. Now for some reason I'm able to repro audio not working with all my games, so I'm not sure whether this is an IE10 or C2 issue. I'm going to raise as a bug.

Edit -> Raised as a bug here: http://www.scirra.com/forum/topic63597_post390097.html

I've been working with IE10 for months now and this is the first time I've seen a problem like this with C2. Very strange. Hopefully it can be resolved soon. thehen2013-02-16 11:25:28
Moderator
B
72
S
13
G
11
Posts: 900
Reputation: 11,783


Return to How do I....?

Who is online

Users browsing this forum: badmoodtaylor, Megavolt and 11 guests