Invisible text on Android?

Discussion and feedback on Construct 2

Post » Mon Feb 06, 2017 4:13 pm

Hi. I tried some of my apps on an Huawei Mate 9 with Android 7.0 and many times simple text objects with the default font are invisible. When I hide/show the layers a few times I sometimes get the text to appear but in most cases its just invisible. But it works fine on Windows Chrome, Edge and iOS. Its just plain Text.

Is there something wrong with the latest beta 242 or is it something in Android 7 maybe?
B
53
S
16
G
6
Posts: 718
Reputation: 9,150

Post » Mon Feb 06, 2017 6:47 pm

Most of the time when I get invisible text, it is because the text box is too small. Try making the text box a little bigger (and maybe try changing Wrapping from Word to Character).

I have also had weird things happen if the layout scale gets zoomed in too far. So that could be an issue.

If all else fails, use sprite fonts - which may improve performance (some platforms seem to suffer from text boxes).
B
94
S
33
G
20
Posts: 438
Reputation: 17,605

Post » Mon Feb 06, 2017 9:22 pm

Thanks, I will try to change the size and see if it helps. But the same invisible text is sometimes visible when I just reload a few times so it should not be the text size?
B
53
S
16
G
6
Posts: 718
Reputation: 9,150

Post » Mon Feb 13, 2017 2:41 pm

It's still happening on Android. But iOS and PC (Chrome/Edge) never had this problem.
Text is sometimes visible but most times its not so it's not the text object size? :-/
B
53
S
16
G
6
Posts: 718
Reputation: 9,150

Post » Mon Feb 13, 2017 3:41 pm

Does it work when exporting into HTML5 and opening it with Chrome on Android?
B
127
S
33
G
17
Posts: 1,549
Reputation: 20,454

Post » Mon Feb 13, 2017 3:55 pm

I had this as well last night.
I only use text boxes for debugging so it was a minor inconvenience and didn't think much of it as on PC and windows tablet it worked fine
but both android phones no text.
the same text had previously worked

Will investigate tonight....
...
B
42
S
21
G
7
Posts: 260
Reputation: 7,683

Post » Mon Feb 13, 2017 5:18 pm

@glerikud I will try it.
So far I tested it in preview on Edge/Chrome on PC and via LAN Preview on iPhone and Android Phone. And its in the Play Store as Alpha and when I download it with my Android phone its the same problem, text is invisible most times.
B
53
S
16
G
6
Posts: 718
Reputation: 9,150

Post » Thu Feb 16, 2017 10:42 pm

@Bl4ckSh33p

So I found...

.If I disable webGL the text comes back to android

could you try that see if it works?

But then I made a default start up C2 project and put some text in and no issues. hmm

[edit] right, I disabled one of my debug text boxes and all the other text boxes came back even when webgl enabled

so maybe that was causing issue or chrome on android doesn't like too many text boxes. maybe you have similar situation.

FYI the general advice is to use sprite font for text in game / app as normal text boxes will kill performance especially if they are being updated regularly.....
...
B
42
S
21
G
7
Posts: 260
Reputation: 7,683

Post » Mon Feb 20, 2017 1:30 pm

Sorry for the delay, could not try it yet but I hope I have some time today or tomorrow to do some testing again.
B
53
S
16
G
6
Posts: 718
Reputation: 9,150


Return to Construct 2 General

Who is online

Users browsing this forum: Colludium and 4 guests