Invoke Download not working properly

Bugs will be moved here once resolved.

Post » Thu Mar 06, 2014 7:39 pm

Problem Description
Invoke Download works locally in "Run Layout," but does not work when live on a web page. It appears to be behaving as "Open URL in New Window" instead.

Attach a Capx
http://thekidzpage.com/notworking/wontinvokedownload.capx
*This is the example .capx included with Construct 2 (aka: Example: Taking screenshots)

Description of Capx
Take screenshot then invoke download.

Steps to Reproduce Bug
  • Click/Tap Button: "Take screenshot"
  • Click/Tap Button: Download

Observed Result
Image opens in new window (as in "Open URL in New Window" command, rather than the "Invoke Download" command as specified) No error message is present.

Expected Result
Dialogue box opens to request download location for image to save

Affected Browsers
  • Chrome: YES
  • FireFox: YES
  • Internet Explorer: YES
  • Opera: YES

Operating System and Service Pack
Windows 7, Service Pack 1

Construct 2 Version ID
Construct Release 163

*Also tested on and affects: Chrome and Safari using iPad Mini

Live Demo

http://thekidzpage.com/notworking/
You do not have the required permissions to view the files attached to this post.
B
18
S
3
G
2
Posts: 28
Reputation: 2,704

Post » Fri Mar 07, 2014 10:53 pm

IMHO , even if it is open in a new url under the name "data:" you can click right and save picture as.
ImageImageImageImageImage
B
59
S
18
G
5
Posts: 852
Reputation: 11,746

Post » Sat Mar 08, 2014 7:35 pm

Thanks for your feedback, Naji :) However, it's a feature that was present and working in previous versions and I already use it in my games, so I'd prefer that the bug be fixed rather than ignored.
B
18
S
3
G
2
Posts: 28
Reputation: 2,704

Post » Wed Mar 12, 2014 8:16 pm

Looks like the minifier broke the feature detection (opening a new window is a workaround for browsers without invoke download support). Fixed for the next build; workaround in the mean time is to disable minification on export.
Scirra Founder
B
414
S
245
G
92
Posts: 25,207
Reputation: 200,355

Post » Wed Mar 26, 2014 7:09 am

Thanks Ashley. Great news :)
B
18
S
3
G
2
Posts: 28
Reputation: 2,704

Post » Fri Mar 30, 2018 9:16 am

Hello.
Sorry to unearth this topic but I have the same problem but with IE only (tested on version 11 on 2 computers).

It opens in base64 in a new tab. It does not offer the download.
B
6
S
1
Posts: 60
Reputation: 524

Post » Fri Mar 30, 2018 10:27 am

christ59 wrote:Hello.
Sorry to unearth this topic but I have the same problem but with IE only (tested on version 11 on 2 computers).

It opens in base64 in a new tab. It does not offer the download.

@christ59

As it states in the sticky, you should not be posting in a closed bug report, especially one from 4 years ago.

Either create a new bug report, following ALL of the Bug Report Requirements, or maybe ask for help in the 'How Do I' section.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
145
S
33
G
89
Posts: 5,921
Reputation: 62,607


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest