iOS audio distorted/missing with background apps

Bugs will be moved here once resolved.

Post » Fri Jan 22, 2016 7:42 pm

iOS 9.3.1 Beta installed and the problem persists.
B
8
S
1
G
1
Posts: 10
Reputation: 945

Post » Sat Jan 23, 2016 7:27 pm

Checkout this blog post: http://www.williammalone.com/posts/ios- ... ile-issue/

When I tested the sound in that link using my iPhone the first "touchstart" audio is distorted but the other two are fine. Try that link out on an iPhone to reproduce the grainy audio.

Looks like if you use "touchend" the audio plays fine.
B
9
S
2
G
5
Posts: 54
Reputation: 3,546

Post » Wed Jan 27, 2016 10:22 am

I'm on iOS 9.2.1 and if I browse to my game in safari audio works fine but if I pin it to the home screen then launch it there's no audio at all. I can even switch right back to safari and audio continues to work.
B
4
Posts: 10
Reputation: 222

Post » Fri Feb 12, 2016 5:05 pm

Original .capx link is no longer working, so we can't investigate this any further. This is missing review for the r222 release cycle. Please provide a .capx link that works or the issue will be closed.
Scirra Founder
B
395
S
231
G
88
Posts: 24,367
Reputation: 193,684

Post » Sun Feb 14, 2016 5:42 pm

@majesticAsFk can you post the .capx?
B
9
S
2
G
5
Posts: 54
Reputation: 3,546

Post » Tue Feb 16, 2016 12:24 pm

One other idea to try when there is a .capx again: if this is to do with switching to the home screen/another app and then coming back, it might be worth trying enabling "play in background" in the Audio object properties. Normally switching away and coming back will suspend and resume the audio context, but if you enable that option it just leaves it running. This might help identify if the problem stems from suspending the audio context.
Scirra Founder
B
395
S
231
G
88
Posts: 24,367
Reputation: 193,684

Post » Tue Feb 16, 2016 2:04 pm

@Ashley thanks for the feedback and idea - I am going to test this out later this week.
B
9
S
2
G
5
Posts: 54
Reputation: 3,546

Post » Sat Feb 20, 2016 11:18 pm

Feel free to close the bug or @mars1985 if you wouldn't mind attaching a capx.
Half way through professional development of my game I've had to switch to Unity because of this and other issues.
This has caused me major stress and financial set back and I find the developers response to the issue and general view towards its customers unacceptable. I have essentially purchased software which is not fit for purpose, it's the developers attitude to such problems why the engine will never be considered a serious option for professional developers.

For what it's worth my initial tests integrating an external JS audio framework was working fine.
B
13
S
4
Posts: 65
Reputation: 875

Post » Sun Feb 21, 2016 9:40 pm

@majesticAsFk we have another thread going with a lot of people with the same problem. I've seen this problem posted about over and over without being seriously addressed. I guess if a dozen people start complaining about it then we may see some traction.

We were able to resolve the audio distortion problem but now the audio won't run on the first run after install. viewtopic.php?f=151&t=167412&p=1016939#p1016939

Thanks for your feedback - I am looking to switch over to Unity - its unfortunate that this isn't more support for iOS with Construct 2. I really like how easy Construct 2 is to use but if I can't properly export it to iOS then its useless and a waste of time.
Last edited by mars1985 on Sun Feb 21, 2016 11:33 pm, edited 1 time in total.
B
9
S
2
G
5
Posts: 54
Reputation: 3,546

Post » Sun Feb 21, 2016 10:50 pm

mars1985 wrote:@Ashley thanks for the feedback and idea - I am going to test this out later this week.


@Ashley I tested enabling play in background on the Audio properties which resolved the minimize bug where you minimize the the app or switch to the home screen that your app loses sound completely.

The first run bug (no audio) is still an issues after converting the audio sample rates to 48000khz to resolve the audio distortion.
B
9
S
2
G
5
Posts: 54
Reputation: 3,546

PreviousNext

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests