iOS Intel XDK experiences

Discussion and feedback on Construct 2

Post » Fri Dec 05, 2014 11:50 pm

Hey everyone, I've been using intel XDK for android for a while now, with great success. But what are the steps to publish to iOS using xdk?
B
43
S
12
G
6
Posts: 446
Reputation: 6,807

Post » Tue Dec 30, 2014 9:18 pm

Hi,

I tried many, many times, but I'm still unable to build successfully an iOS app using Intel XDK. All the signing process seem to be correct, I added the provisioning file and stuff, and when building the app here is what I get :

"
The build failed.
An error occurred while building the application. Verify your build assets are correct and try again.

Building a Cordova 3.5 application.
The application name is "Healer Quest"
The package name is "----------------------"
Will use the provisioning profile for "adhoc"
Plugin "Device" (org.apache.cordova.device) installed.
Plugin "SplashScreen" (org.apache.cordova.splashscreen) installed.
Plugin "AdMob Plugin" installed.
Plugin "https://github.com/cranberrygame/com.cranberrygame.phonegap.plugin.iap#430---------------------46c1" installed.
Plugin "org.apache.cordova.inappbrowser" installed.
Targeting iOS version 7.
Copied HQ_icon6_76.png (76x76) image file to icon-76
Copied HQ_icon6_152.png (152x152) image file to [email protected]
Copied HQ_icon6_60.png (60x60) image file to icon-60
Copied HQ_icon6_120.png (120x120) image file to [email protected]
Copied HQ_icon6_180.png (180x180) image file to [email protected]
Copied the iPhone 6 Landscape [rablo_games_logo1334.jpg] (1334w x 750h) splash screen to [email protected]
Copied the iPhone 6 Plus Landscape [rablo_games_logo2208.jpg] (2208w x 1242h) splash screen to [email protected]
Copied the iPad Retina Landscape [rablo_games_logo1496.jpg] (2048w x 1496h) splash screen to [email protected]~ipad.
Copied the iPad Landscape [rablo_games_logo1024.jpg] (1024w x 748h) splash screen to Default-Landscape~ipad.
Warning: No splash screen supplied for iPad Retina portrait (1536w x2008h). The default will be provided.
Warning: No splash screen supplied for iPad portrait (768w x1004h). The default will be provided.
Warning: No splash screen supplied for iPhone Retina (640w x960h). The default will be provided.
Warning: No splash screen supplied for iPhone 6 Plus Portrait (1242w x2208h).
Warning: No splash screen supplied for iPhone (320w x480h). The default will be provided.
Warning: No splash screen supplied for iPhone 5 (640w x1136h). The default will be provided.
Warning: No splash screen supplied for iPhone 6 Portrait (750w x1334h).
An unexpected error occured while attempting to build the application.
"


The only errors seem to be the missing splash screens for portrait mode, but I actually added these splashscreen ! (despite my game being played in landscape only)

Am I missing something?
B
33
S
6
G
1
Posts: 355
Reputation: 2,850

Post » Wed Dec 31, 2014 12:10 pm

@rable - any chance you can post the full build log? if you want, you can email me ian.maffett at intel.com and I'll be happy to look into it
Intel Corporation
B
5
S
2
Posts: 133
Reputation: 871

Post » Wed Dec 31, 2014 2:32 pm

Many thanks for the help, it now builds successfully ! As you highlighted I had to create a mobileprovision from the certificate.
Didn't know they had to be related to each other !
B
33
S
6
G
1
Posts: 355
Reputation: 2,850

Post » Thu Feb 05, 2015 10:44 am

Rable wrote:Many thanks for the help, it now builds successfully ! As you highlighted I had to create a mobileprovision from the certificate.
Didn't know they had to be related to each other !


Hi @Rable could you please explain this? It seems you were missing the provisioning files, but how did you do a build in the XDK without them? Thanks.
B
24
S
9
G
4
Posts: 1,646
Reputation: 6,596

Post » Thu Feb 05, 2015 10:29 pm

I've just tried to publish a test app that simply has a single sprite on a layout.
I've read lots of tutorials. Using XDK v 1621

I have a Developer account
I have an app ID, call it com.company.product
I have a registered device (iPad)
I have an ad hoc provisioning profile showing the same App ID, 1 certificate and 1 Device
I have another provisioning profile (how can you tell which is ad hoc or not, only by the name I gave it??) showing the same App ID, 1 Cert and 0 devices
I have no development provisiong profiles, as per what I've read, but I wouldn't thought I'd need one? (judging by the name)

In the XDK I created a new project for the test app
App ID set as above
Version 1.8.2 (as per my existing Android version)
Full screen
Landscape
iOS target 5
Provisioning profile Ad hoc
Ad hoc provisioning profile: set to the adhoc xxx.mobileprovision file
Production provisioning profile: set to the other xxx.mobileprovision file
As a first test I did not add any icons or splash screens
I did not alter the plugins

Build tab, build, upload
Build page says iOS CERTIFICATE: Step complete. If i choose Edit, it says 1a: "Your CSR has been generated..." etc. and 1b: Certificate uploaded..." etc.

I get all warnings about "no images provided" and "no splash screen".. and "An unexpected error occurred"

Next step I will add icons and splash screens and re test.

Thanks for any help.

Edit: added icons and splash screens, got the errors about some further splash screen sizes, so added those images and added them to the 'intelxdk.config.additions.xml' file. No warnings now, just the same error at the end.

@imaffett can I send you the build log?
B
24
S
9
G
4
Posts: 1,646
Reputation: 6,596

Post » Mon Feb 09, 2015 9:40 pm

This is still not working for me, please see above.

edit: I managed to get a test app installed so I should be able to work out my real app
B
24
S
9
G
4
Posts: 1,646
Reputation: 6,596

Post » Sat Feb 21, 2015 12:18 am

Hello

I've been trying to make this work for a while now but all I get is "The certificate was not created with the Certificate Signing Request."

I even deleted my certificate and did the steps shown again with a new one but I still get this msg. How do I solve this?
B
9
S
1
Posts: 30
Reputation: 539

Post » Sat Feb 21, 2015 12:33 am

I'm about to go out but if the problem is not resolved I'll post something later. Basically I deleted certificate and everything else and started over like you said you did.
B
24
S
9
G
4
Posts: 1,646
Reputation: 6,596

Post » Sat Feb 21, 2015 1:18 am

a tip for you @codah is to have the iOS target to 5.1.1 or ells apple will reject it

I still have no idea what I should do :/ I even created my own CSR on my mac and tried it on windows as I have all the files there but still nothing. why does apple have to be so complicated! On andorid it was so simple

Edit: well the certificate problem is solved as I exported a p12 file

now I just got to fix the image problems and see if the last error. be sure you are in the right tab as I accidentally added all images to android instead of iOS and now I have to recreate everything in those sizes lol
B
9
S
1
Posts: 30
Reputation: 539

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 7 guests