Is "Audio/preloads complete" event useless?

Discussion and feedback on Construct 2

Post » Thu Sep 18, 2014 2:32 pm

ok thanks i'll try that -
but just to clarify -
using the preload sounds in project properties is what caused loading problems in safari... using preload from eventsheet and the other one turned off seemed to work - at least the game stopped having load problems - but i'm not sure any preloading actually takes place. (using stable build 178)

in the end i ended up doing the following, which seems to be the best solution when i want the game to run fairly well on both android and IOS
1: preload a few important sounds from eventsheet on start of layout
2: remove all refrence to sounds in the exported offline.appcache file

I'll try making a build with the newest BETA build and see how that behaves .. I'll post an update here
Image
Get it on Google play or play on papio.nu
B
11
S
2
Posts: 79
Reputation: 786

Post » Thu Sep 18, 2014 3:05 pm

Ok -
I tried exporting with the BETA 180 build with the following results

Used preload sound from project properties - and that seemed to work well on safari .. sounds were playing instantly and so on...

first time i ran the game everything worked smooth and no problems.. but.. when i try to reload the game it gets stuck again while loading..

I tried editing the offline.appcache again, deleting any reference to the sounds and viola´no loading problems again no matter how many times i reload the game.
so it seems that the main problem lies there.
Image
Get it on Google play or play on papio.nu
B
11
S
2
Posts: 79
Reputation: 786

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 20 guests