issue with spawn

Bugs will be moved here once resolved.

Post » Thu Sep 13, 2012 3:47 pm

There is something strange about spawning sprites.

Player_Ship is spawning 4 object in total - 2 different and 2 same with different instance name variable.
Every object is spawn on a specific image point.

When you run project it look like one of the Player_Ship_Engine_Side object (the one one left wing) is flickering and there is one more extra object on Back_Engine, flickering as well.

Same thing happens when you switch object spawn to system create or when you change image points from names to numbers


I found the way to fix that by simply moving event 2 below event 3 so it spawns Engine_Back first and after that Laser_Light and Engine_Sides.


I'm using r103 on win 64, here's the file: spawn issue.capx
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Thu Sep 13, 2012 6:52 pm

It looks OK in r103.2 (a quiet update). Have you tried that?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Thu Sep 13, 2012 7:04 pm

Yes, it's the same on r103.2

here's short movie
it was recorded at 30fps

thing is that when Player_Ship_Engine_Back is spawn before or after Player_Ship_Engine_Side - this thing happens

but when you move Player_Ship_Laser_Light between those two it's fine.



Edit: one more thing.
If Engine_back is spawn before Engine_Side - left engine is flashing
If Engine_back is spawn after Engine_Side - right engine is flashing :Dshinkan2012-09-13 19:05:44
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Fri Sep 14, 2012 12:14 am

Your video shows orange flames which flicker.
In your .capx I see blue flames which do not flicker.

Not sure what's going on here, seems we're seeing different things. Did you test different browsers? Are all browsers the same?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri Sep 14, 2012 12:40 am

ohh, sorry didn't noticed that

It's the same thing... compression on video shifts hue in color
Here's normal one
http://dl.dropbox.com/u/34375299/issue.avi

I've tried that in chrome 21 and IE9 - it's all the same.
Only when exporting to *.exe it looks normal

and after playing around, I've noticed that Glow (horizontal or vertical) and Tint effects used together was causing that flicker to appear
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Fri Sep 14, 2012 1:05 am

Hmm... still looks fine on two computers that I've tried now.

Sounds like it might be an issue with the effects system... in which case, do you have the latest graphics card drivers?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri Sep 14, 2012 1:17 am

Yes I do have the latest graphics card drivers.

but anyway
[QUOTE=shinkan]I found the way to fix that by simply moving event 2 below event 3 so it spawns Engine_Back first and after that Laser_Light and Engine_Sides.][/QUOTE]

why it's working after doing that?
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Fri Sep 14, 2012 12:14 pm

@Ashley i've made one more video with some more weirdness...

longer video

It seems like there's something with preview.
Exporting to awesomium *.exe works fine, and exporting to html5 to dropbox works fine as well.
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Fri Sep 14, 2012 5:16 pm

If it's a graphics card driver bug, all bets are off - anything could change it.

Your video doesn't play in Windows Media Player, did you use an uncommon encoder?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri Sep 14, 2012 6:50 pm

no idea what codec did I used, but this one works ^^

It might be a graphics card driver, but won't this flickering show everywhere?
For now it only shows in preview. After exporting to html5 or exe there is no flickering.
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests