Issues with movement

Get help using Construct 2

Post » Thu May 12, 2016 8:14 pm

I've created a game for a school project, and have been updating it to work with touch controls today. However, whenever I try to make my player move, the animation plays but the sprite remains still. The line of code looks like this:

Touch | Is touching LEFT_ARROW | Player - Stimulate 8Direction pressing left
-------------------------------------------------| Player - Set animation to "Left" (Play from beginning)

If anyone knows what I'm doing wrong, please help me as this is rather urgent.

Thanks in advance.
B
4
S
1
Posts: 2
Reputation: 300

Post » Fri May 13, 2016 12:31 am

Simulate 8Direction pressing left is already in there and you just updated it to work with touch control? Does this mean you have some other control schemes? If so, are the other control schemes conflicting each other? Ex. do you have anywhere in your event sheet that sets the speed of the 8direction to be 0?
I got a game that you multiply, breath fire with two heads and brawl foes to oblivion with your clones: http://www.newgrounds.com/portal/view/660664 (use Chrome on Windows for best performance)

My sites:
http://twinblazar.deviantart.com
http://twinblazar.newgrounds.com
https://twitter.com/twinblazar
http://www.pixiv.net/member.php?id=15072448
B
30
S
11
G
11
Posts: 411
Reputation: 8,469

Post » Fri May 13, 2016 6:43 am

Originally it worked with keyboard controls, but I replaced them with the touch controls. They're the only control scheme in the game.
B
4
S
1
Posts: 2
Reputation: 300


Return to How do I....?

Who is online

Users browsing this forum: AkbarAsgharMG, Governador and 24 guests