issues working with CocoonjS and C2 r187(with solutions)

Discussion and feedback on Construct 2

Post » Sat Nov 08, 2014 12:36 pm

Hey all

I've tried using the new cocoonJS plugin, and have found several issues preventing me from testing it, browser and launcher due to multiple JS errors.
Here are the solutions that made it possible (finally!)

Problem
Getting C2 error:

Condition: FileExists(min_js)
File: html5.cpp
Line: 1693
Function: void __cdecl Exporter::DoExport(class era::IProject *,class era::ILayout *,bool,struct HWND__ *,bool,bool)
Build: release 186 (64-bit) checked
Component: HTML5 exporter
(Last Win32 error: 2)

Solution
The new cocoonjs plugin edittime.js has a typo when using dependency "achievement_locked.png". Make sure the name of the image and the dependency are the same.

Problem
Getting JS error (Launcher only):

jQuery is undefined (got it from "jquery.equalheights.js")

Solution
In the new cocoonjs plugin edittime.js, the "jquery.equalheights.js" dependency appears before "jquery-1.8.3.min.js". Just switch them so that it loads jquery first.

Problem
Getting JS error:

ILLEGAL TOKEN (got from "Webstorage_common.js")

Solution
common.js in the webstorage plugin of C2 is totally empty, as opposed to other common.js files which has 2 comment lines in them, a thing that causes JS error trying to load an empty file. It's enough to put "//" inside the file to make the error go away.

Problem
Getting JS error in the custom launcher:

"FB is undefined"

Solution
I've noticed the latest custom launcher from cocoonjs (2.1 compiler) pops up this error, while the signed apk of 2.0.2 works just fine.
I've filed a bug with ludei found here: http://support.ludei.com/hc/communities ... onstruct-2

Feel free to join there as well, if you encounter it also.


After those fixes, I managed to run the new cocoonJS plugin correctly on my mobiles.

Hope it helps anyone :)
Last edited by trueicecold on Sat Nov 08, 2014 6:17 pm, edited 1 time in total.
B
18
S
7
G
1
Posts: 157
Reputation: 1,928

Post » Sat Nov 08, 2014 1:37 pm

Thanks!
B
12
S
2
Posts: 70
Reputation: 1,074

Post » Sun Nov 09, 2014 3:44 pm

@Ludei, could you look at these issues?
B
12
S
3
G
1
Posts: 188
Reputation: 1,377

Post » Sun Nov 09, 2014 5:19 pm

Well, i have a bigger problem. In 2.1 the tiled background disappears, replaced by a blu background :(
B
6
S
1
Posts: 73
Reputation: 569

Post » Sun Nov 09, 2014 6:00 pm

@pcprice76, with CocoonJS? weird, I've tested tiled background and all was ok...
B
18
S
7
G
1
Posts: 157
Reputation: 1,928

Post » Sun Nov 09, 2014 9:43 pm

I would also post this info on the github https://github.com/ludei/Construct-2-plugin Click on issues and post it there. They seem to check there most often.
B
101
S
32
G
11
Posts: 1,546
Reputation: 21,667

Post » Mon Nov 10, 2014 7:52 am

@ArcadEd Thanks, I added their issues in there as well :)
B
18
S
7
G
1
Posts: 157
Reputation: 1,928

Post » Tue Nov 11, 2014 9:32 am

Hello,

Thanks a lot for this bug report with all the solutions. It is really helpful :). We need to test if, after doing these changes, there are problems with the previous versions of C2, as we need to get focused on the stable version (r184 right now).
Regarding Facebook issue, we will investigate it. However, could you please confirm me that it only happens with the combination of r187 + 2.1 launcher? Have you tested if the compiled project works?

pcprice76 wrote:Well, i have a bigger problem. In 2.1 the tiled background disappears, replaced by a blu background

If you send us a capx that reproduces the issue, we will have a look at it :). If possible, please, use our community and provide us with all the information you can (device, OS version, C2 version, steps to reproduce, ...). And remember we never ask for a full game. It is enough with a small example that reproduces the exact error you want us to see :).

Regards.
B
9
S
4
G
4
Posts: 383
Reputation: 3,616


Return to Construct 2 General

Who is online

Users browsing this forum: Apollo14, JesusJ, ZeZin232 and 13 guests