Javascript error > Is that my fault?[SOLVED]

Get help using Construct 2

Post » Thu Apr 19, 2018 8:02 pm

Hey there,

I've run into this message, on chrome, internet explorer, with version r257.2 :

"Source : localhost:50000

Javascript error!

Uncaught ReferenceError: a is not defined
http://localhost:50000/preview.js , line 4610 (col9)"

NW.js just freezes, like when you have a neverending loop.

Does that mean I've done something, that isn't supposed to be done, that I can fix myself, or is it a legitimate bug? It seems to happen when objects with the platform behavior land on tilemaps and/or Tiledbackgrounds, but I haven't been able to reproduce it on a new project, so there's more to it...? But I had no such issue before r257 and its .2 update, although I think I remember the error message being different before the latter.
Last edited by VonFirflirch on Fri Apr 20, 2018 11:33 am, edited 1 time in total.
B
16
S
3
Posts: 54
Reputation: 1,023

Post » Fri Apr 20, 2018 11:27 am

Generally JavaScript errors are bugs and should be filed in the Bugs forum following all the guidelines. In this case I think you've run in to an already reported issue with that beta release.
Scirra Founder
B
415
S
248
G
92
Posts: 25,287
Reputation: 200,958

Post » Sun Apr 22, 2018 4:04 pm

Did you find where that come from?

I got the same issue.
B
3
Posts: 2
Reputation: 179

Post » Sun Apr 22, 2018 4:37 pm

Phil4courriel wrote:Did you find where that come from?

I got the same issue.


Have you download the latest beta r257.3 and tested it?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
147
S
33
G
89
Posts: 5,988
Reputation: 62,791

Post » Mon Apr 23, 2018 1:46 am

Thanks for the message that works now with the r257.3!!
B
3
Posts: 2
Reputation: 179


Return to How do I....?

Who is online

Users browsing this forum: blackhornet, Flat Office, IronHeart and 65 guests