Jerky Performance

Discussion and feedback on Construct 2

Post » Mon Jul 29, 2013 7:35 pm

I have created my game in Construct2 but one issue I have is every 4 seconds or so the sprites jerk slightly in the game. There are only 5 or 6 sprites on the screen.

I have also reduced the collision points to the absolute minimum - between 4 and 6.

Each sprite is 120x65. There are 5 frames repeating at a speed of 7 but even with just 1 frame it still jerks.

No particles/effects/scale/flip/blend modes used.


I have tried everything to reduce this and it occurs on my PC in Firefox (or IE). Same issue on my iPad (iPad4 - 1024mb RAM, retina display).

Using the CocoonJS app I get 62FPS. I have built the game in the Cocoon cloud and the issue is also there.

I am using r139 64 bit, OpenGL 3.3.11672.


The game - download size 19.3 mb, memory use 158mb (was 173mb but after optimizing I have it down to 158).

Background image - 122kb
Layers - 4 (bg, main, HUD, Touch controls)

Use loader layout - No
Pixel rounding - On
Preview browser (default)
Fullscreen in browser - Scale
Use iOS retina display - All devices
Enable WebGL - On
Sampling - point
Clear backgrround - No


My PC - Win 7 64 3Ghz, 3Gb RAM, ATI Radeon HD 4800 (latest driver).

So I'm stuck right now - please help!
B
10
Posts: 30
Reputation: 940

Post » Mon Jul 29, 2013 9:06 pm

can you post a link/cap of your game?

you need to provide more info because it could be just a simple image point misplaced on one of the frames or something off scirra engine, like a extension is being loaded behind your browser, causing it some sort of lag...valdarko2013-07-29 23:09:24
B
48
S
5
G
6
Posts: 210
Reputation: 6,277

Post » Mon Jul 29, 2013 10:26 pm

Are you using bullet behavoir or bounce? I had something similar in a game I am making using Cocoon. Lags when objects bounce =( I have not found a fix yet
B
37
S
10
Posts: 188
Reputation: 3,818

Post » Mon Jul 29, 2013 11:59 pm

I've been trying to narrow this down....

My game features pretty much just two sprites on each layout - player and enemy. The same enemy is just spawned again. I have switched enemies from different layouts and it seems not to be an issue such as an image point with a sprite.

As mentioned it happens with the browser, in Cocoon launcher and in my Cocoon built app so its coming from Construct2 as not all the devices can be at fault.

I am using bullet behaviours - will try some sprites without them and see what happens.
B
10
Posts: 30
Reputation: 940

Post » Tue Jul 30, 2013 1:22 am

No it happens with sprites that just use Custom Movement also.
B
10
Posts: 30
Reputation: 940


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 5 guests