Jump Animation Issues

For questions about using Classic.

Post » Tue Feb 28, 2012 10:50 pm

Been banging my head against a wall over this for an hour now. Finally caved in and am asking for help

I've found this thread: http://www.scirra.com/forum/jumping-animation_topic43196.html which outlines an identical issue, but I'm still confused.

Basically, I can't get both my running and jumping animations to play well together. I can get one of them working perfectly, but then the second will be stuck on a random frame - not animating. It depends which is higher up the list of events.

I'll attach a screenshot of my event list for animations below. Perhaps it's to do with the way I handled checking for direction with the D and A keys (I'm using WASD for movement at the moment). As for the Inversed Condition for the jump event - that was my latest attempt. In the thread I linked to above the solution was to use the events 'Player Is On Ground' and 'Player Is NOT On Ground'. I couldn't see the NOT On Ground Event anywhere, so wondered if you had to use the Invert command to get it. I just had the 'Player Is Jumping' Event before, which is now a sub-event. Either way it isn't working.

Anyone see where I'm going wrong? No doubt it's painfully simple

-Silver-2012-02-28 22:52:03
B
15
S
7
G
7
Posts: 250
Reputation: 5,298

Post » Wed Feb 29, 2012 11:55 am

Solved it. Took a good look at DeadEye's fantastic Platform School animation events, and applied something similar to my own game.

Ended up with this, for anyone from the future with a similar issue:

B
15
S
7
G
7
Posts: 250
Reputation: 5,298


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 4 guests